Frame rate preference does not work on Mac Chrome

version: docker-jitsi-meet , stable-6865
description:

case 1:

My config.js configuration is as follows:

config.resolution = 2160;
config.videoQuality.preferredCodec = 'VP9';
config.constraints.video.height = { ideal: 1080, max: 2160, min: 360 };
config.constraints.video.width = { ideal: 1920, max: 3840, min: 600};
config.constraints.video.frameRate = { ideal:30 ,max: 60, min: 25};
config.enableLayerSuspension = false;
config.disableSimulcast = false;

There are two 2160p and one 1080p cameras in the session:
Mac Chrome: 2160 p
Unbuntu Chrome: 2160p, 1080p
When I focused on Mac Chrome, it showed a frame rate of 10-15 with a resolution of 3920x2160
When I focused on Ubuntu Chrome 2160p it showed a frame rate of 30 and a resolution of 2560x1440

case 2:

My config.js configuration is as follows:

config.resolution = 1440;
config.videoQuality.preferredCodec = 'VP9';
config.constraints.video.height = { ideal: 1080, max: 1440, min: 360 };
config.constraints.video.width = { ideal: 1920, max: 2560, min: 600};
config.constraints.video.frameRate = { ideal:30 ,max: 60, min: 25};
config.enableLayerSuspension = false;
config.disableSimulcast = false;

There are two 2160p and one 1080p cameras in the session:
Mac Chrome: 2160 p
Unbuntu Chrome: 2160p, 1080p
When I focused on Mac Chrome, it showed a frame rate of 30 with a resolution of 2560x1440
When I focused on Ubuntu Chrome 2160p ,it showed a frame rate of 30 and a resolution of 2560x1440

I can see logs in Mac Chrome console:

setting max height=2160,maxBitrates=200000,500000,1500000,encodings={"codecs":[{"clockRate":90000,"mimeType":"video/VP9","payloadType":101,"sdpFmtpLine":"x-google-start-bitrate=800"},{"clockRate":90000,"mimeType":"video/VP8","payloadType":100,"sdpFmtpLine":"x-google-start-bitrate=800"},{"clockRate":90000,"mimeType":"video/H264","payloadType":107,"sdpFmtpLine":"level-asymmetry-allowed=1;packetization-mode=1;profile-level-id=42e01f;x-google-start-bitrate=800"},{"clockRate":90000,"mimeType":"video/rtx","payloadType":96,"sdpFmtpLine":"apt=100"},{"clockRate":90000,"mimeType":"video/rtx","payloadType":97,"sdpFmtpLine":"apt=101"},{"clockRate":90000,"mimeType":"video/rtx","payloadType":99,"sdpFmtpLine":"apt=107"}],"headerExtensions":[{"encrypted":false,"id":5,"uri":"http://www.ietf.org/id/draft-holmer-rmcat-transport-wide-cc-extensions-01"},{"encrypted":false,"id":3,"uri":"http://www.webrtc.org/experiments/rtp-hdrext/abs-send-time"}],"rtcp":{"cname":"VtYB1048dBJbwQu/","reducedSize":false},"encodings":[{"active":true,"adaptivePtime":false,"networkPriority":"low","priority":"low"},{"active":true,"adaptivePtime":false,"networkPriority":"low","priority":"low"},{"active":true,"adaptivePtime":false,"networkPriority":"low","priority":"low"}],"transactionId":"1cb2d059-7dcf-489c-8bb5-4f29ca4bee55","degradationPreference":"maintain-framerate"}

I want it to be framerate first, what should I do?

Try setting “ideal” and “max” video resolution as the same.

config.constraints.video.resolution = { ideal: 1080, max: 2160, min: 360};

Is this the configuration above? It doesn’t seem to work

There is no such configuration in the jitsi-meet code, are you sure it is working

This problem only occurs in Mac Chrome which is version 101

I meant, try:

config.constraints.video.height = { ideal: 1080, max: 1080, min: 240};

well… It also works in case 2, but the problem is that it can’t adjust the frame rate when I configure high resolution