[FIXED] You have been disconnected

Hello,

We use Rocket Chat and Jitsi Meet on our private local network (no NAT, no public access).

I managed to install Jitsi Meet on a dedicated virtual machine (Ubuntu 18.04), with a dedicated FQDN and IP address. Rocket Chat and Jitsi work well.

But it was just for testing.
We need to be able to install Rocket Chat + Jitsi Meet on the same virtual machine (Ubuntu 18.04 also).

So I did the following:

  1. Our DNS has been updated so that the FQDN dedicated to Jitsi is now associated with our VM RocketChat
  2. on our existing Rocket Chat virtual machine, I modified /etc/hosts to include the new fully qualified domain name (just in case, the DNS server is ok)
  3. I installed Jistsi meet using apt instal jitsi-meet (our existing server already has Nginx installed)
  4. The installation used the fully qualified host name to configure Jitsi. So I edited the configuration of Nginx and Jitsi to use the dedicated FQDN for Jitsi (so no conflict with RocketChat)
  5. When creating a video call, the Jitsi window appears, but we always stay at the message “You have been disconnected”.

What should I do to make Jitsi work?

What did I miss?

Thanks for your help guys!

Can you paste the JS console output?

How can I retrieve it ?

Please follow the steps .
1.Right click on browser page
2. Select the inspect
3.Click console,
4. On console page you can see errors and those console log have to share here then we can recognise what is issue.

Thanks

As I can’t upload files, there’s the link: https://pastebin.com/mMmqbsPp

Regards,

Your bosh connection is not working:

VM102 lib-jitsi-meet.min.js:6 POST https://conference.mydomain.com/http-bind?room=rocketchatyenogbrkss9h4nzl4n3ag9staradrdpglerddirlxg9c3rcrbik 404 (Not Found)

The http-bind location in nginx config is missing.
When working it should look like: https://meet.jit.si/http-bind

Your nginx config for jitsi-meet should look like:

Thanks for your replies.

This is the case. I’ve just modified some parameter to be good as the link send by @damencho.

Please take a look at the ngins vhost here:https://pastebin.com/tejnEYzN

I don’t understand.

There’s the new console output (since minor changes on vhost due to @damencho reply): https://pastebin.com/HMAKSi6n

Many thanks for your help !

If this is your config it seems fine, make sure it is used by nginx.
Check nginx logs on restart, it may have some conflicts with other hosts or something …

Found it !

I’ve missed reconfiguring prosody with dedicated FQDN and recreating certificates used by prosody.

Works fine now.

Thanks for your help

Im having the same issue right now. Can I have some more information on how you found what was wrong? and how you went about fixing it.

thanks

1 Like

https://meet.vmeetz.com/http-bind
I have all setup done for authentication but seems to get nowhere