<fixed. please ignore>"make" throw "Makefile:18: recipe for target 'compile' failed"

env:
ubuntu 18.04
npm: 6.9.0
nodejs: v10.16.3
repo: git clone https://github.com/jitsi/jitsi-meet.git

firstly, I run npm install. the output show some warn.
then I run make:
./node_modules/.bin/webpack -p
Makefile:18: recipe for target ‘compile’ failed
make: *** [compile] Killed

the output of npm install:

git-validate@2.2.2 install /opt/jitsi-meet/node_modules/git-validate
node bin/install

node-sass@4.10.0 install /opt/jitsi-meet/node_modules/node-sass
node scripts/install.js

Downloading binary from https://github.com/sass/node-sass/releases/download/v4.10.0/linux-x64-64_binding.node
Download complete ] - :
Binary saved to /opt/jitsi-meet/node_modules/node-sass/vendor/linux-x64-64/binding.node
Caching binary to /root/.npm/node-sass/4.10.0/linux-x64-64_binding.node

precommit-hook@3.0.0 install /opt/jitsi-meet/node_modules/precommit-hook
node bin/install

core-js@3.2.1 postinstall /opt/jitsi-meet/node_modules/@babel/register/node_modules/core-js
node scripts/postinstall || echo “ignore”

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon:

https://opencollective.com/core-js
https://www.patreon.com/zloirock

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)

final-form@4.12.0 postinstall /opt/jitsi-meet/node_modules/final-form
node -e “console.log(’\u001b[35m\u001b[1mUsing final-form at work? You can now donate to our open collective:\u001b[22m\u001b[39m\n > \u001b[34mhttps://opencollective.com/final-form/donate\u001b[0m’)”

Using final-form at work? You can now donate to our open collective:

https://opencollective.com/final-form/donate

styled-components@3.4.9 postinstall /opt/jitsi-meet/node_modules/styled-components
node ./scripts/postinstall.js || exit 0

Use styled-components at work? Consider supporting our development efforts at opencollective.com/styled-components

lib-jitsi-meet@github:jitsi/lib-jitsi-meet#503d47f3639cbd313489d2845d8dba96fc7b0ba5 postinstall /opt/jitsi-meet/node_modules/lib-jitsi-meet
webpack -p

Browserslist: caniuse-lite is outdated. Please run next command npm update caniuse-lite browserslist
Hash: 6fbdd3d861076ecc1432
Version: webpack 4.26.1
Child
Hash: 6fbdd3d861076ecc1432
Time: 22817ms
Built at: 08/22/2019 5:17:55 AM
Asset Size Chunks Chunk Names
lib-jitsi-meet.min.js 661 KiB 0 [emitted] [big] lib-jitsi-meet
lib-jitsi-meet.min.map 2.53 MiB 0 [emitted] lib-jitsi-meet
Entrypoint lib-jitsi-meet [big] = lib-jitsi-meet.min.js lib-jitsi-meet.min.map
[2] ./JitsiConferenceEvents.js 8.63 KiB {0} [built]
[3] ./modules/browser/index.js 98 bytes {0} [built]
[4] …/jitsi-meet-logger/lib/index.js 3.6 KiB {0} [built]
[5] ./modules/statistics/statistics.js 28.5 KiB {0} [built]
[8] ./service/statistics/AnalyticsEvents.js 17.1 KiB {0} [built]
[9] ./service/RTC/MediaType.js 110 bytes {0} [built]
[11] ./modules/util/GlobalOnErrorHandler.js 2.37 KiB {0} [built]
[12] ./JitsiTrackErrors.js 2.51 KiB {0} [built]
[13] ./modules/RTC/RTC.js 35.4 KiB {0} [built]
[15] ./JitsiTrackError.js 5.95 KiB {0} [built]
[16] ./JitsiTrackEvents.js 1.31 KiB {0} [built]
[17] ./JitsiConferenceErrors.js 2.12 KiB {0} [built]
[20] ./modules/videosipgw/VideoSIPGWConstants.js 1.44 KiB {0} [built]
[119] ./index.js 160 bytes {0} [built]
[120] ./JitsiMeetJS.js 19.4 KiB {0} [built]
+ 137 hidden modules

WARNING in asset size limit: The following asset(s) exceed the recommended size limit (244 KiB).
This can impact web performance.
Assets:
  lib-jitsi-meet.min.js (661 KiB)

WARNING in entrypoint size limit: The following entrypoint(s) combined asset size exceeds the recommended limit (244 KiB). This can impact web performance.
Entrypoints:
  lib-jitsi-meet (661 KiB)
      lib-jitsi-meet.min.js


WARNING in webpack performance recommendations:
You can limit the size of your bundles by using import() or require.ensure to lazy load some parts of your application.
For more info visit https://webpack.js.org/guides/code-splitting/

node-sass@4.10.0 postinstall /opt/jitsi-meet/node_modules/node-sass
node scripts/build.js

Binary found at /opt/jitsi-meet/node_modules/node-sass/vendor/linux-x64-64/binding.node
Testing binary
Binary is fine
npm WARN lifecycle jitsi-meet@0.0.0~postinstall: cannot run in wd jitsi-meet@0.0.0 jetify (wd=/opt/jitsi-meet)
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/jest-haste-map/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

added 2018 packages from 1042 contributors and audited 80402 packages in 160.873s
found 2193 vulnerabilities (3 low, 2 moderate, 2187 high, 1 critical)
run npm audit fix to fix them, or npm audit for details

issue fixed.

@xiran_li I am encountering the same issue. How did you fix it?

have you checked the npm and nodejs version ?

@xiran_li I installed the latest LTS 10.6.3 node and npm, also the latest release. I ran npm audit fix and then make. It’s taking a long time to build then I would receive something like your error and make process killed. I checked the CPU utilization and it is at 100% even with AWS 30gb t2 micro instance (free tier). I’m just curious how were you able to fix yours? Thanks a lot.