First-time install not working at all, all steps completed

Hello everyone,

I completed the installation of Jitsi-Meet with no errors, or should I say I don’t see the errors (see logs below):

JICOFO.LOG
:/var/log/jitsi# less jicofo.log
Jicofo 2022-07-17 12:20:19.268 INFO: [1] JitsiConfig.#47: Initialized newConfig: merge of /etc/jitsi/jicofo/jicofo.conf: 1,system properties,reference.conf @ jar:file:/usr/share/jicofo/jicofo.jar!/reference.conf: 1
Jicofo 2022-07-17 12:20:19.323 INFO: [1] ReadOnlyConfigurationService.reloadConfiguration#51: loading config file at path /etc/jitsi/jicofo/sip-communicator.properties
Jicofo 2022-07-17 12:20:19.345 INFO: [1] ReadOnlyConfigurationService.reloadConfiguration#56: Error loading config file: java.io.FileNotFoundException: /etc/jitsi/jicofo/sip-communicator.properties (No such file or directory)
Jicofo 2022-07-17 12:20:19.347 INFO: [1] JitsiConfig.#68: Initialized legacyConfig: sip communicator props (no description provided)
Jicofo 2022-07-17 12:20:19.466 INFO: [1] JitsiConfig$Companion.reloadNewConfig#94: Reloading the Typesafe config source (previously reloaded 0 times).
Jicofo 2022-07-17 12:20:23.689 INFO: [1] JicofoServices.createAuthenticationAuthority#196: Authentication service disabled.
Jicofo 2022-07-17 12:20:24.586 INFO: [1] XmppServices.#48: No dedicated Service XMPP connection configured, re-using the client XMPP connection.
Jicofo 2022-07-17 12:20:24.599 INFO: [1] XmppServices.#63: No Jigasi detector configured.
Jicofo 2022-07-17 12:20:24.709 INFO: [1] BridgeSelector.#57: Using org.jitsi.jicofo.bridge.SingleBridgeSelectionStrategy
Jicofo 2022-07-17 12:20:24.755 INFO: [1] [type=bridge brewery=jvbbrewery] BaseBrjicofo.log
Jicofo 2022-07-17 12:20:19.268 INFO: [1] JitsiConfig.#47: Initialized newConfig: merge of /etc/jitsi/jicofo/jicofo.conf: 1,system properties,reference.conf @ jar:file:/usr/share/jicofo/jicofo.jar!/reference.conf: 1
Jicofo 2022-07-17 12:20:19.323 INFO: [1] ReadOnlyConfigurationService.reloadConfiguration#51: loading config file at path /etc/jitsi/jicofo/sip-communicator.properties
Jicofo 2022-07-17 12:20:19.345 INFO: [1] ReadOnlyConfigurationService.reloadConfiguration#56: Error loading config file: java.io.FileNotFoundException: /etc/jitsi/jicofo/sip-communicator.properties (No such file or directory)
Jicofo 2022-07-17 12:20:19.347 INFO: [1] JitsiConfig.#68: Initialized legacyConfig: sip communicator props (no description provided)
Jicofo 2022-07-17 12:20:19.466 INFO: [1] JitsiConfig$Companion.reloadNewConfig#94: Reloading the Typesafe config source (previously reloaded 0 times).
Jicofo 2022-07-17 12:20:23.689 INFO: [1] JicofoServices.createAuthenticationAuthority#196: Authentication service disabled.
Jicofo 2022-07-17 12:20:24.586 INFO: [1] XmppServices.#48: No dedicated Service XMPP connection configured, re-using the client XMPP connection.
Jicofo 2022-07-17 12:20:24.599 INFO: [1] XmppServices.#63: No Jigasi detector configured.
Jicofo 2022-07-17 12:20:24.709 INFO: [1] BridgeSelector.#57: Using org.jitsi.jicofo.bridge.SingleBridgeSelectionStrategy
Jicofo 2022-07-17 12:20:24.755 INFO: [1] [type=bridge brewery=jvbbrewery] BaseBrewery.#100: Initialized with JID=jvbbrewery@internal.auth.meet.MYSITE(dot)com
Jicofo 2022-07-17 12:20:24.766 INFO: [1] JicofoServices.#121: No Jibri detector configured.
Jicofo 2022-07-17 12:20:24.767 INFO: [1] JicofoServices.#127: No SIP Jibri detector configured.
Jicofo 2022-07-17 12:20:24.913 INFO: [1] JicofoServices.#142: Starting HTTP server with config: host=null, port=8888, tlsPort=8843, isTls=false, keyStorePath=null, sendServerVersion=true.
Jicofo 2022-07-17 12:20:25.268 INFO: [15] [xmpp_connection=client] XmppProviderImpl.doConnect#209: Connected, JID=null
Jicofo 2022-07-17 12:20:25.490 INFO: [15] AvModerationHandler.registrationChanged#120: Discovered av_mo:

JVB.LOG
/var/log/jitsi# less jvb.log
JVB 2022-07-17 12:19:54.498 INFO: [1] JitsiConfig.#47: Initialized newConfig: merge of /etc/jitsi/videobridge/jvb.conf: 1,application.conf @ jar:file:/usr/share/jitsi-videobridge/jitsi-videobridge.jar!/application.conf: 1,system properties,reference.conf @ jar:file:/usr/share/jitsi-videobridge/jitsi-videobridge.jar!/reference.conf: 1,reference.conf @ jar:file:/usr/share/jitsi-videobridge/lib/ice4j-3.0-58-gf41542d.jar!/reference.conf: 1,reference.conf @ jar:file:/usr/share/jitsi-videobridge/lib/jitsi-media-transform-2.2-9-g8cded16e.jar!/reference.conf: 1
JVB 2022-07-17 12:19:54.570 INFO: [1] ReadOnlyConfigurationService.reloadConfiguration#51: loading config file at path /etc/jitsi/videobridge/sip-communicator.properties
JVB 2022-07-17 12:19:54.580 INFO: [1] JitsiConfig.#68: Initialized legacyConfig: sip communicator props (no description provided)
JVB 2022-07-17 12:19:54.622 INFO: [1] JitsiConfig$Companion.reloadNewConfig#94: Reloading the Typesafe config source (previously reloaded 0 times).
JVB 2022-07-17 12:19:54.736 INFO: [1] MainKt.main#90: Starting jitsi-videobridge version 2.2.9-g8cded16e
JVB 2022-07-17 12:19:56.618 INFO: [11] org.ice4j.ice.harvest.MappingCandidateHarvesters.createStunHarvesters: Using 193.122.183.200:443/udp for StunMappingCandidateHarvester (localAddress=172.26.4.165:0/udp).
JVB 2022-07-17 12:19:57.247 INFO: [12] org.ice4j.ice.harvest.StunMappingCandidateHarvester.discover: Discovered public address 100.26.14.210:52786/udp from STUN server 193.122.183.200:443/udp using local address org.ice4j.socket.IceUdpSocke

PROSODY.ERR
Jul 17 12:20:08 portmanager error Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281
Jul 17 12:20:08 portmanager error Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281
Jul 17 12:46:22 portmanager error Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281
Jul 17 12:46:22 portmanager error Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281

PROSODY.LOG
root@meet:/var/log/prosody# less prosody.log
Jul 17 12:20:00 startup info Hello and welcome to Prosody version 0.11.4
Jul 17 12:20:01 startup info Prosody is using the select backend for connection handling
Jul 17 12:20:01 portmanager info Activated service ‘s2s’ on [::]:5269, []:5269
Jul 17 12:20:01 portmanager info Activated service ‘c2s’ on [::]:5222, [
]:5222
Jul 17 12:20:01 portmanager info Activated service ‘legacy_ssl’ on no ports
Jul 17 12:20:04 c2s561b5bf01190 info Client connected
Jul 17 12:20:04 c2s561b5bf01190 info Client disconnected: connection closed
Jul 17 12:20:08 mod_posix warn Received SIGTERM
Jul 17 12:20:08 startup info Shutting down: Received SIGTERM
Jul 17 12:20:08 general info Shutting down…
Jul 17 12:20:08 general info Shutdown status: Cleaning up
Jul 17 12:20:08 general info Shutdown complete
Jul 17 12:20:08 startup info Hello and welcome to Prosody version 0.11.4
Jul 17 12:20:08 startup info Prosody is using the select backend for connection handling
Jul 17 12:20:08 portmanager info Activated service ‘s2s’ on [*]:5269, [::]:5269
Jul 17 12:20:08 breakout.meet.MYSITE(dot)com:muc_domain_mapper info Loading mod_muc_domain_mapper for host internal.auth.meet.MYSITE(dot)com!

However, when I try to access the site at jitsi.MYSITE(dot)com, Jitsi does not load at all. I get the following error:
“This site can’t be reached:
jitsi.MYSITE(dot)com took too long to respond.
Try:
Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics
ERR_CONNECTION_TIMED_OUT”

However, NGINX is active and running with no errors and responds when you access it with the IP address.

I did successfully installed the LetsEncrypt certificates using the following script:
sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

I apologize for the long post, I just wanted to make sure you had as much information about the problem to make sense of the situation.

I will appreciate any help to get this problem solved.

Please note: I am not a developer but can follow any instructions you give me very well.

Thanks


Jitsi installed on AWS Lightsail
OS: Unbuntu 20.04
Server: NGINX/1.18.0 (Ubuntu)
All up-to-date

This problem has been solved. Thanks.

If you are hosting Jitsi-Meet on AWS Lighsail, the firewall settings of your instance take precedence over any firewall rules you set using UFW as described in the Jitsi implementation guide.

In my case, even though I had the standard recommended UFW firewall settings in the Jitsi installation guide, I did not enable the same settings in my AWS Lightsail settings.

I hope this helps someone.

Thanks for posting your solution.
Just a side note to all who may be reading this and are on different cloud platforms - all cloud-level firewall rules, security groups, etc. take precedence over the local firewall inside the instance. You can think of it as router on top of your internal network (well, sort of).