Firefox works, Chrome, iOS and Android apps keep disconnecting

I have a self-hosted Jitsi Meet setup, no NAT. It works fine from Firefox but the iOS, Android app and Chrome all have an issue whereby it disconnects after a number of second (or maybe it’s 2 minutes). Happens on p2p or multiple parties calls.

The JS Console on Chrome shows it’s the XMPP Ping which times out and after a number of fails, kicks you out.

I am really out of ideas on what to check now. I don’t see anything blocked on the network. I don’t know what this “ping” is trying to do. In the Chrome network tab, I see plenty of successful calls to http-bind and as I wrote earlier, audio and video works totally fine.

As a note, I also have authentication turned on for moderators as covered in https://jitsi.github.io/handbook/docs/devops-guide/secure-domain

Just get kicked out due to this “ping”.

What kind of TLS certificate does your server have?

Let’s Encrypt

Hum, the fact that Chrome fails too is suspicious. Can you paste the full JS console logs when the failure happens?

Yes, my thought too - on other installations I did, Chrome worked best. And it’s strange Firefox does not have this issue.

Here are the JS Console logs:

error.txt (48.4 KB)

OK so it’s probably a networking issue but I can’t put my finger on it due to not understanding what this ping is.

If I have this network topology:

laptop -> firewall -> jitsi
(all on my LAN, no NAT)

I get this problem.

But if I do:

laptop -> VPN to an external server -> firewall -> jitsi

Then it works fine with Chrome.

I think I figured it out - thanks for listening!

I didn’t realize the Jitsi server actually originates traffic to the client. The network routing between the server and the client worked fine on traffic originated by the client (and the server was able to send the response back) but traffic initiated from the server side, the firewall routed the traffic a different route!

Glad you sorted it out!