Fatal error Protocol Version in DTLS response


#1

Problem Statement : When I receive Client Hello from the DTLS Server using DTLS V1.2 . I as a client sending him Server Hello but with DTLS V1.0. As a result I am getting DTLS response Fatal error regarding Protocol Version mismatch or something ?

There is a comment in TlsServerImpl
/**
* {@inheritDoc}
*
* The implementation of TlsServerImpl always returns
* ProtocolVersion.DTLSv10 because ProtocolVersion.DTLSv12
* does not work with the Bouncy Castle Crypto APIs at the time of this
* writing.
*/
@Override
protected ProtocolVersion getMaximumVersion()
{
return ProtocolVersion.DTLSv10;
}

The libjitsi that I am using has bouncy castle version jars as below
bcpkix-jdk15on (1.54)
bcprov-jdk15on (1.54)

The libjitsi master has this version in its pom.xml

org.jitsi
jitsi-universe
1.0-20160405.154511-15

libjitsi
1.0-SNAPSHOT
bundle

When

So can you please help and let me know does libjitsi have a version which supports DTLS V1.2 server side implementation now ? Are there any plans of doing so in near future.

Thanks,
Nilesh