Failing to migrate to JVB2

I’ve had a previously working JVB1 setup, but now am trying to migrate to JVB2 and am not being so successful.

It seems I am stuck on the bridge throwing host-uknown and’ not being available, but that error should not be there since am trying to use the muc (maybe this is just a fallback?)

Config: (Yes, it has passwords, that’s fine with me)

what’s obvious is that jvb can’t connect to prosody. As usual logs are not so clear for the uninitiated, does the
JVB_SECRET in /etc/jitsi/videobridge/config

match the prosody config secret in


I failed to mention my environment.

I’m on Arch Linux and I mostly followed and am running JM, JVB and Jicofo from git.

The --secret that gets to passed to is the same from what I can see

root@meet : /var/lib/prosody/auth%2emeet%2erys%2epw/accounts
[0] # \cat jvb.dat                                     
return {
        ["password"] = "yp0y1ms9f4zm33ni";
[0] # \cat /etc/jitsi-videobridge/jitsi-videobridge.conf
flags="--host=localhost --port=5347 --secret=yp0y1ms9f4zm33ni --api=rest"

–apis=rest seems better to me. Don’t think it’s the main failure but it could explain some of the error messages.

1 Like

Welp. Thanks for catching that.

JVB logs now:

Jvb still don’t seem to be able to authenticate to prosody. Since the calling parameter by jvb seems fine, it could be that prosody config is wrong. My knowledge of prosody is decidedly limited :-), what I know is that you can connect to it using telnet (port 5582) if you have enabled the module, then:


may give you an idea of the reality of prosody config of

The issue with that one was that I had in JVB and Jicofo but in prosody.

After changing all to, I can now make 1on1 calls.

Third participant joining still crashes the meeting, meaning the JVB still doesn’t work as it should.

Here’s logs from when the third participant joins, am unable to make out anything useful from it myself:

it’s the #1 on hit parade of this forum. And indeed there is a suspicious pair failed with port 10000 / udp message. Is there a NAT involved ? if yes are you not missing something like

Is there a NAT involved ? if yes are you not missing something like

Yes and yes, THANK YOU!

I’ve had that config in there at some point but removed it while I was trying things out.

Once again, thanks a lot, I’ll see about fixing the manual install docs when JVB2 is packaged in the generic linux downloads (