Failing to Get Jibri to Work on Debian 10

This is my first time here, so apologies for any errors.

I have not been able to get Jibri to work on Debian 10.
In jibri.conf, when I do not initialize strip-from-room-domain, there is a recording, but it is of an empty room (AFAIK), and in the logs, jibri is accessing ‘’. When I initialize strip-from-room-domain to ‘conference.’, recording does not start.

Since I am a new user, it will not let me post my jibri.conf, as it contains too many links.

Logs please

I am not sure how to do this, as I cannot upload files, as I am a new user. Should I cut and paste them into a post?

@gregork check out #5 and #6 - [TIP] Fastest Way To Get Support In The Forum

Here are the logs and the jibri.conf file.
log.0.txt (14.4 KB) ffmpeg.0.txt (8.3 KB) browser.0.txt (638.7 KB) jicofo.log (45.5 KB) jibri-clean.conf.txt (5.0 KB)

First problem: in your jibri.conf, you have the values set incorrectly

domain : "",

should be

domain = "",

This misconfiguration is repeated several times in the file. You need to fix that.

Also, those last logs show that it looks like ffmpeg was killed while running?

Thanks. I changed all the ‘:’ to ‘=’, and restarted everything, but still got the same result.

As I said, when I did not have strip-from-room-domain defined in jibri.conf, I got as long recording as I want, but it is not of the right meet (see attached snapshot), and recording fails after a short time when strip-from-room-domain is set to the correct value (“conference.”). From that, it seems to me that the chrome and ffmpeg are working, but I have misconfigured something so that chrome is unable to attach to the correct meet.

What version of java are you running?

I have openjdk-8-jdk-headless installed.

I meant openjdk-8-jre-headless

Maybe clear your logs, restart Jibri, try to do a recording, then share the logs.

Check the status of Jibri service to see if it’s running.

1 Like

I’m also on Debian 10 Buster. And initially I also couldn’t get recording to function, because I used java-8. But once I removed java-8 and installed java-11, the default in Debian 10, and followed the tutorial at TUTORIAL - How to Install the NEW JIBRI it works, except for the java-8 part.
Also note that if you have a password on the room, or have lobby-mode enabled, recording will not start, more info at Live streaming/recording (jibri) does not work if room has a password · Issue #659 · jitsi/docker-jitsi-meet · GitHub

Thanks. The tutorial worked very well, except I needed to use java-8, as java-11 resulted in an inability of Jibri (I assume) to gracefully stop ffmpeg, resulting in a corrupt video.
I also had problems with ffmpeg failing due to lack of memory. Though 2GB is the suggested minimum, I needed to upgrade to 4GB to keep ffmpeg from failing.