Failed to Verify Let'sEncrypt

I receive a “connection refused” error when I am trying to verify the Let’sEncrypt Certificate for a new Jitsi installation. I believe that I have properly forwarded all of the ports and set the protocols correctly.

I am at a loss trying to figure out what the problem is. Below is a screenshot of my firewall port forwarding rules that I have set up for Jitsi.

If this is an Ubuntu box, UFW (the firewall on the server) may be an issue. Still not resolved check my installer

@emrah, it is an Ubuntu box. I thought I had disabled the firewall, but either I didn’t or that wasn’t the issue.

When following your script, what do I do with the “export” lines? Not very informed when it comes to Linux commands.

When installing jitsi, two host addresses are needed:

  1. jitsi host address
  2. TURN host address

export lines set these two addresses and the installation script handles the installaion steps according to their values.

What is the TURN host?? Is it the same as the Jitsi host?

TURN is a service on the same host that helps clients who cannot directly connect to the videobridge service (another service that manages the media traffic)

So the hostname should be the same for both?
Also, when I try to run the export command, I receive “export: command not found”.

No, the host addresses are different. The host will have two different addresses (one for TURN and one for jitsi). But both addresses point the same IP address

Okay, gotcha.
I have successfully ran the export command, but the script still tells me “Set the Jitsi host address according to the following command and try again.”

It seems that your default shell is not bash. Could you try to switch to bash shell before the export lines:

bash

export JITSI_HOST=jitsi.yourdomain.com
export TURN_HOST=turn.yourdomain.com

bash jitsi-buster-installer

Still giving the same error.
When I run just “export” it lists all of the variables, and it has JITSI_HOST=“my_hostname”. I’m wondering if it is giving the error because of the quotation marks.

Could you send me the console screenshot as a private message?
The commands you entered and their outputs…

I feel like a complete idiot! The only thing that was keeping it from working was the fact that I didn’t type “sudo” in front of “bash”. I didn’t even think to try it.

So, now, after I’ve wasted your time, I’ve got the server live. I cannot thank you enough for your patience with me. Windows is my thing, obviously, Linux isn’t.

Only issue now is that the meetings won’t connect, but I assume that’s a firewall issue of some kind. Still working to figure that one out.

If the installation completed using this script, there should be no connection issues because the installer checks the firewall condition too

If it’s OK for you, I can connect through SSH and can check your server. I wondered why not working correctly

Sure! Fine with me…
I will PM you the info.

webmin issue… Fixed after changing the webmin port

Awesome, thank you for figuring this out.

1 Like