Failed to load config from local deployment

Android app is having problem loading config.js from the locally deployed jitsi meet instance.

I have looked at the previous posts related to this error and have already applied the solutions but the problem persist.

[features/base/lib-jitsi-meet] Failed to load config from https://xxxx.xxxx.com/config.js?room=a Error(AbortError){"message":"Aborted","stack":"Error: Aborted\n at anonymous (index.android.bundle:135:6514)

  1. SSL certificates are properly setup for the domain with the intermediate CA certificates.
  2. The app works fine when I use https://meet.jit.si url.
  3. The ios app works fine with local instance’s url.
  4. the url https://xxxx.xxxx.com/config.js?room=a fetches the data appropriately in the mobile browser.

The code is identical to android sdk sample code.

Please let me know if you require any additional information.

Thank you very much for your help.

I have the same error and I am waiting for response

Your android app need chain certificates from your web server.

To add it to your server (apache example):

  1. Get files from your web server certificate issuer: i.e. intermediate_CA1.crt intermediate_CA2.crt

  2. If have more than one put all intermediate certificates into one file:

cat intermediate_CA1.crt <(echo) intermediate_CA2.crt > intermediate.crt

  1. Copy file to your web server certificate place

cp intermediate.crt /etc/ssl

  1. Update web config file (for apache /etc/apache2/sites-available/example.com.conf) by adding line:

SSLCertificateChainFile /etc/ssl/intermediate.crt

  1. Restart web server

service apache2 restart

  1. Enjoy your android app :slight_smile:
1 Like

Thanks a lot
I installed jitsi meet in Apache server .
Can you tell me what are intermediate_CA1.crt and intermediate_CA2.crt?

Look at your web server certificate path.


Intermediate certification authorities are all certification authorities beetween root CA and your domain certificate. You should get its certificates from your web server certificate issuer.
I assume you have qualified certificate.

Just for people’s awareness, the error was not related to CA certs as I had set them properly. After digging into the react source code I found that this error {"message":"Aborted","stack":"Error: Aborted\n at anonymous is invoked due to timeout. The mobile client aborts the call if response is not received within the set timeout. After increasing the timeout, the app started working.

dear bertx
we have no purchased certificate at all and we use this for local network.
just we have self signed certificate in our web server .
is there any solution to work with jits i and android in local network with no internet?

can u say in which file i have to change the timeout and how to do it.
Thank you in advance

Hello ,
I have nginx webserver please help me with this.

in this like they didn’t mentioned that apache or nginx
Thansk

Hi @pabsituation
triggered the same issue , can you please tell me where you increases the timeout. That will be of great help to me.

Thank you !!!

I have the same problem. Have you solved it?