"Failed to Access your microphone"

No matter the browser, desktop/mobile, browser settings/permissions, webview/iFrame, webrtc tests, clear cache, or selection of mic source… I get the same error message every time about the failure to access the microphone. Only jitsi gives this error as the mic works with other applications. I ran through dozens of forum posts, and none of the suggestions work. I am all out of options and unable to find any solution. Unless this is a Jitsi glitch that Jitsi can fix on their end, then this might be the end of Jitsi for me.

Can anyone help?

Is this on your private server or on meet.jit.si?

Thanks for replying Freddie! So, hosting is from meet.jit.si. However, I think I found the culprit which probably has little-to-nothing to do with Jitsi. My jitsi meet URL is contained within an HTML embed window featured in a Wix web page. From what I understand, Wix has its own container in which the HTML content (my Jitsi URL) is wrapped and the coding behind the Wix container is likely blocking access/permission to the mic. I tried the jitsi URL in a new tab in my browser and the mic works fine. But when I open the Wix webpage that holds the Jitsi HTML page inside its own webviewer or iframe, then access to the mic fails. I don’t even know where to start in trying to fix this from the Wix back end.

Maybe reach out to Wix support? They should be able to offer some insight on which of their packaged code could be blocking the microphone element.

I did… now waiting for a reply. Not sure if it’s something that a workaround can be had, much less if they’re willing to remove whatever is blocking the access.

Wix was absolutely no help. In fact, after saying they could (or would) not help, they tried to sell me on SEO packages, without the slightest bit of shame.

Nevertheless, I think there is a fix in adding the allow microphone/camera attributes in an iframe. Do you know if the same can be Achieved with parameters added to the URL? Thanks.

The iframe API already does that jitsi-meet/external_api.js at f560eecfa9766c767c9856bd2e951cc5e17e58c1 · jitsi/jitsi-meet · GitHub

Are you following the iframe API docs?

@damencho Thanks. But, without inserting the allow attributes in the iFrame with the URL, it simply doesn’t work. They key is to reference the allow parameter with the jitsi meet URL. E.G.<iframe… allow=“camera https://meet.jit.si/{********}; microphone https://meet.jit.si/{*******}”>

If you are using the iframe api as described here IFrame API · Jitsi Meet Handbook there is a code creating the iframe and adding the correct allow parameters.

I also experience this. Try this. Go to Safari, then click Safari in the upper left, then click setting for this website, then Microphone: instead of deny, choose ask or allow.

Too weird. Since the fix from many months ago, the iframe for Jitis worked fine with the "allow parameters. Then suddenly, this evening it stopped working. I could not for my life figure out what changed despite resetting and clearing Chrome.

1 Like

Wow, no replies, suggestions, or comments. Is this site still active?

Try Mozilla

for me, i got the exact same error when running jitsi meet (self-hosted) via iframe in an android flutter app. same code worked fine in web app, and fine on ios. the jitsi meet link worked fine in chrome, just not via iframe. yesterday and before it was working great across all platforms, today i got the mic error on the android device. what solved it was explicitly requesting mic permission in the app.