Facing issues while connecting to meeting

Dear Team,

We have installed the Jitsi via docker. We are facing issues while trying to connect when there are many participants in the room else the connection and communication is fine… Kindly let us know how we can over come this and where we have to make the changes inside the docker.

Awaiting your kind reply on the same.

Many thanks

Welcome to the forum.

When you say “many participants”, how many are you talking about? And what are your server specs?

Dear Freddie,
Greetings!!
Thank you for your update.
Up to 35 participants the connection and communication seemed to be fine.
At the same time we couldn’t locate the path “/etc/prosody/” inside the prosody docker .
Please advice.

What are your system specs, though? RAM, CPU e.t.c…

Hi Freddie,

Please find the server specs below

OS: CentOS Linux 7 (Core) x86_64
CPU: Intel Xeon E3-1270 v5 (8) @ 4.000GHz
Memory: 32GB

Your specs don’t look bad. So you’re saying after 35 people, you have performance problems? What’s your bandwidth like?

HI Freddie,

The server Bandwidth is fair enough ,please find the details below
Latency: 1.02 ms (0.06 ms jitter)
Download: 925.12 Mbps (data used: 609.2 MB)
Upload: 924.25 Mbps (data used: 427.6 MB)

As you don’t quite explain what are the issues, it’s dificult to help. Are you sure that the ‘issues’ are at the server level (did you monitor it ?) or at the workstations level ? 35 users displayed simultaneouly on a screen can weigh heavily on a system, given that browsers are basically monothreaded systems. I’t’s often recommanded to disable sound level indications as a first level optimization, and even to use lastN to not display too much users on the screen. As the human eye is only seeing details in a very limited area, displaying 50 people on a screen is not so useful anyway.

Dear Team,

The overall participants today were not more than 120. Only 4 rooms were running parallel and each room had not more than 20 to 30 participants.

. Following values were tweaked

A)suspend unused video layers until they are requested again, to save up resources —>enableLayerSuspension: true
B)Limit video resolution to 480 --> resolution: 480
C)show videos of last 4 active speakers only although everyone has video enabled channelLastN: 4
D) Deactivate webcams after the 5 participant --> startVideoMuted: 5

  1. Teaked the value in the variable JAVA_SYS_PROPS under the file /etc/jitsi/jicofo/config, ,
    JAVA_SYS_PROPS="-Dorg.jitsi.jicofo.MAX_SSRC_PER_USER=100"
    ====================================
    Kindly advise us on how to proceed to disable sound level indications.

Awaiting your further reply on the same.

Thank you

1 Like

DearTeam,

Please be noted that there are no issues at the server level, kindly advise on the parameters to optimize further so that we can accommodate more joinees per room to attend the session.