Extreme audio latency Jitsi meet 2.0.4857-1

Hello,

I installed Jitsi yesterday on a Digital Ocean droplet (8 GB RAM, Ubuntu 18.04 server, nginx). Everything is working like a charm except that there is extreme audio latency. I tested it with a colleague and the latency is so extreme that Jitsi is unusable. It’s approx. 8-10 seconds behind. What could be up / down? Here are the version details:

ii jitsi-meet 2.0.4857-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4289-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-turnserver 1.0.4289-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.4289-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4289-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-273-g072dd44b-1 all WebRTC compatible Selective Forwarding Unit (SFU)

And these packages are installed as well:

ca-certificates-java coturn fontconfig-config fonts-dejavu-core java-common jicofo
jitsi-meet jitsi-meet-prosody jitsi-meet-turnserver jitsi-meet-web
jitsi-meet-web-config jitsi-videobridge2 libavahi-client3 libavahi-common-data
libavahi-common3 libcups2 libevent-core-2.1-6 libevent-extra-2.1-6
libevent-openssl-2.1-6 libevent-pthreads-2.1-6 libfontconfig1 libgd3
libhiredis0.13 libjbig0 libjpeg-turbo8 libjpeg8 liblcms2-2 libmysqlclient20
libnginx-mod-http-geoip libnginx-mod-http-image-filter
libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-stream libnspr4
libnss3 libpcsclite1 libpq5 libtiff5 libwebp6 libxi6 libxpm4 libxrender1 libxtst6
lua-bitop lua-event lua-expat lua-filesystem lua-sec lua-socket lua5.1
mysql-common nginx nginx-common nginx-core openjdk-8-jre-headless prosody ssl-cert
x11-common
Perhaps I’m missing something. Thanks in advance for your help!
Best,
Deborah

I have seen posts from people struggling with using Jitsi on smallish DO servers like 500 Mb Ram. If it’s the same sort of VPS it’s not powerful enough.

Hello, thanks for getting back to me. The droplet has 8 GB RAM so that can’t be it

If you don’t have connectivity problems (can be tested with ping and looking for lost packets in a not very precise but easy way) maybe it could be some sort of weird P2P network problem. Could you try again with setting

p2p: {
enabled: false,

in the your-domain-config.js file ?

Hello, ping results look good:

11 packets transmitted, 11 received, 0% packet loss, time 10234ms

I’m a bit of a noob. I entered the config file but it’s empty, is this correct or should I see other settings in there?

Thanks :slight_smile:

well, the your-domain part should be replaced by your real domain; if it’s meetings.example.com, you should edit /etc/jitsi/meet/meetings.example.com-config.js. That’s what is understood on this forum when ppl say ‘just edit your config.js’.

1 Like

Awesome! It did the trick, I’m so happy, thank you!
Lovely day and best,
Deborah

It’s still an indication that not everything is right in the world because it should work :slight_smile:

1 Like