External Api/ IFRAME options not working on self hosted

Hi there,
Am trying to setup an iframe using external api on my self hosted jitsi, been stuck with some issue for few days, and i appreciate any help.
before posting this question here, i have taken the effort to carefully read and try the options on

#1 APP_NAME in interfaceConfigOverwrite has no effect.
#2 brandingDataUrl in configOverwrite has no effect.
#3 can not seem to be able to disable the webApp but only allow iframe.
#4 always keep getting pwa-worker.js error. pwa-worker.js (failed)net::ERR_INSECURE_RESPONSE
Thanks in advance.

@Freddie perhaps you could help with this one.

This is intentional. If you want to customize them you should run your own deployment and set them directly in interface_config.js.

We don’t support this. The iframe “just” loads the full web, so I’m not sure how you could disable the web and just allow the iframe usage?

You can ignore that, it should be fixed with the next release.

Hi @saghul Thanks for your reply.
If you notice on my question i stated that am using self hosted instance. on my self hosted jitsi, ....
And the problem stands as is, most of the options are none functional.
I wish to add
#5 is it possible not to host external_api instead have the api and app files locally on my vue-js app?

The answers are still valid. Those options are not overridable from the external API, you must configure the interface_config.js file in your installation.

Yes, you can bundle the external_api.js file with your app. Just take it from your own install.

Hi, i just tried modifying the file. No luck.
To be clear by bundling here i mean eliminating the need for hosting the jitsi-meet web app, and have it within my app, is that feasible?

No, you definitely need a server running that will handle the client traffic.
Or you you can use the meet.jit.si site if you don’t want to self-host.
If you want your own branding with jitsi API but not host your own, you can opt for a paid plan from Jitsi. Contact the Jitsi team for the quote