Etherpad integration in Jisti for ios application

HI@sagul

I have Jitsi code compile of older version around 6 month older. I need to implement etherpad in my jitsi version . Please guide me how can I achieve this.

Update to the newest version, this is already implemented.

I have older version of Jitsi which I compiled and created Jitsi framework, which I am using in my native application. I did the following steps

  1. Took etherpad folder from your latest repository and replace that with my older version of jitsi code.
  2. When I run the jitsi code , it run successfully and on the menu options I can see the Open shared document button.
    But problem is when I click on this button nothing happen. Is there any special thing I need to do ?

For your Information:- Etherpad is integrated on my local server. I also tried your live app. I replaced your server url with my server url , at this point etherpad is working working fine in your live app.

But not in the jitsi code that we compiled.

Please guide.

Update. I can’t support frankenbuilds where you copy and paste a directory and hope for the best, sorry.

Oh… OK Saghul one last questions. When I create framework by compiling the code, I get jitsi.framework. Please tell me how can I reduce the size of the framework. Currently I am getting it around 130MB size on xcode 11.2.
What files I can remove just to use jitsi.framework for IOS application.

Thank you

Are you using bitcode?

YES, bitcode is enabled

Then that is the expected size. Don’t worry about it, Apple will thin it after uploading.

Hi @saghul

I have compiled the latest jitsi code for IOS. And it’s running fine. On my local server iI have setup for Etherpad. There are following scenarios:-

  1. I tried the website jitsi call on my local server and in that Etherpad is working fine.
  2. I downloaded the jitsi app from itunes and on my local server etherpad is working fine on your live mobile app also.
  3. Now I just clone the latest jitsi code for sdk and compiled it, Its running fine but Shared document i.e. Etherpad is not working in this case. When I click the shared doc button nothing happens.

Please tell me hat settings we need to do so that that etherpad works fine. I can see the share doc button.

Regards
Chandra

Can you share your deployment URL?

YES ,

https://meet.melpapp.com:8090

I think the problem is we don’t properly support non-absolute URLs on mobile. Can you please try to update your interface_config.js to have as full URL, ie, starting with https://

is it working at your end?

I haven’t tried it, but I know the relative URL is a problem.

OK, but Saghul thing is that same url is working on live app but not on the jitsi code.

Oh crash, sorry, I misunderstood. Do you get any logs?

NO, that’s why I am saying please once use this url on the code and see if its working at your end.

If it work , please tell me what you did. so that I can also apply the same changes.

I just tested on our latest beta (straight from master) and it worked fine.

oh… I can’t find issue on my side.

hey saghul
Can you help me related to this issue ?

Is it related to any add on feature in provisoning profile ?