Etherpad installation and integration on Jitsi

Hey guys,

Sorry for the question in advance, if there’s already a topic on how to do this, I just couldn’t find a proper one with actual info for 2021 after the config file replacement for Ubuntu 20.04.

I’m new to Ubuntu and an university student, I’m trying to learn how to setup a Jitsi meet server with a lot of functionalities that would be useful for hosting lectures, meetings, etc.

I’m running an Ubuntu server and have already configured Jitsi and Jibri with recording and live-streaming.

The issue I’m having now is with the installation of Etherpad and its integration in a Jitsi meet conference (as an add-in with a button in the functionalities menu during a conference).

Can anyone provide a guide with instructions and detailed steps on how to incorporate Etherpad on the Jitsi meet server ?

@Freddie As you were able to assist me in the past with a recording issue, maybe you can help out here as well, if you have some time and are able to ?

Thank you a lot in advance and once again - apologies, if the topic has already been raised.

Check these:

Hi, I have checked these but I don’t think they’re adapted for the new Jibri - I tried implementing the steps from the first topic, however I’m not able to open the Jitsi web page after I put the etherpad_base: 'https://etherpad.“your domain”:9001/p/‘ in the config file.

Any ideas how to implement this for the new configuration after September, 2020 ?

If possible, please provide full steps, as I’m still a beginner with Linux (how to properly set up everything via the command prompt)

Once again - thanks to everyone in advance.

Follow this link. Note that you have to put the nginx related block, for etherpad, in ssl block of the config file.

If you want to simply access etherpad, not from inside jitsi meeting, you need to open firewall port 9001/tcp and access it using http(not https).

Hi, I think I got it to work:

The function button appeared in the menu, I’m able to click on it and get the interface for the document:

Can you let me know how I can load a document too ?

I’ve tried with ( is my webpage) and with - however none opened the menu.

Thank you a lot in advance !!!

Modify localhost:9001 in nginx conf file, to And restart nginx.

Is etherpad running? Are you able to access etherpad directly?

How can I access the nginx conf file ? And how can I access etherpad directly ?

(Sorry for the stupid questions)

Did you follow the steps from ‘Etherpad addition example’ link provided above? The nginx conf file is in step 2.

You can access directly using http://yourdomain:9001

Yeah, I did.

So, I changed it like this now:

and restarted nginx with sudo systemctl reload nginx

However, I’m unable to access it directly: doesn’t load

  1. Is it running? Did you start using as explained on link. If it is running you should see some process listening on port 9001 when you type: netstat -antp|grep 9001.

  2. As explained in a comment before, did you open port 9001, in firewall?

Yes, it’s running:

I allowed the port with sudo ufw allow 9001/tcp and checked but I’m not seeing the port 9001 listed:

Btw, just to mention, I’m running the Jitsi server on AWS, maybe the port should be opened there on the instance too ?

Stop the service and simply run it using src/bin/ and then check.

Later you may go back to running it as a service if it works.

Where did you open the port then? This needs to be done on the server where you have jitsi and etherpad installed. That’s it.

The src/bin/ command doesn’t do anythin.

I will open the port on the AWS instance at the security groups and try again, then let you know.

You are doing it wrong.

  1. Goto directory where you have etherpad-lite
  2. Then do: ./src/bin/

And you can see etherpad is running towards the end.

Ok, I did it, it had me to type: Etherpad rocks my socks , apparently I shouldn’t start it as root.

But it’s running:

I opened the 9001 port on the server and rebooted it, it doesn’t load now:

But the web page without 9001 loads normally

Now is it not working from inside jitsi?

All the information that you need to get it running is available on this thread. You need to figure it out now.