Etherpad - Black Screen in Jitsi. But working seperately

I am getting this black screen when I am opening the Shared Document(Etherpad) in Jitsi Meet.

I got this error from the browser console -

I can access Etherpad from my serverip:9001. But not with the domainname:9001

I have also set the server block in nginx.

https://github.com/jitsi/jitsi-meet/wiki/Etherpad-addition-example

Etherpad is installed in /opt/etherpad-lite

Ubuntu 18.04. Latest nightly build of Jitsi(as on 29.04.2020).

Please advise how can I get Etherpad working in Jitsi.

1 Like

Any solution to this?

Hi there!
Maybe you have not used HTTPS:// for the etherpad_base command in your jitsi meet config.js

It needs to look like this:

etherpad_base: 'https://domain.com/etherpad/p/',

If you can only access it from local network, then your webserver config might be wrong.

As I said I couldn’t access it with my subdomain name. But I can access with the ip.

Means Etherpad is not opening when I try to open it with -

https://subdomain:9001 or http://subdomain:9001

But I can open it with only - http://ip:9001 .

Not with https://ip:9001

I have checked every setting in the settings.json of Etherpad changing it to localhost, 127.0.0.1. None of it works. I have kept it to 0.0.0.0 or ""

Also, checked the nginx server block. I created the entry for Etherpad from the Jitsi wiki page of Etherpad installation.

The bottom line is that I can only access Etherpad externally with - http://ip:9001.

But not with subdomain name with or without https.

Hi
In case of subdomains, you need at least a cname record pointing to it. Are you owning a domain name?

yes, I am owning it. It’s a Google domain.

Hi,
What do you mean with Google domain?

Are you having a cname or A record pointing to the subdomain?

I replied to your question that own a domain at Google Domain.

Yes, I have a A record. The server ip is set in the A record of the subdomain.

As I said in my post that Jitsi is setup and accessible. If the A record was not setup, then how I would have accessed Jitsi. The SSL certificate won’t have installed without a proper A record.

The issue I am facing is with Etherpad only accessible by the ip of the server - ip:9001

Not by the subdomain name.

And I am getting a black screen in Jitsi if I try to open Etherpad inside Jitsi.

I would guess the black screen is coming from the not accessible etherpad. How does your apache/nginx config looks like?

Based on that “Mixed Content” message, I might suggest attempting to enable SSL for etherpad.

Then test https://fqdn:9001/ in your browser.

If that works, then maybe set up jitsi’s nginx config to point there too:

proxy_pass https://fqdn:9001/;

Edit: Or your browser settings for the FQDN can be changed to allow all content even insecure. Maybe try this first before messing with SSL.