Errors on jvb startup

Hello I am getting following error in jvb logs

  1. org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: ‘localhost:5222’ failed because: localhost/127.0.0.1 exception: java.net.ConnectException: Connection refused (Connection refused)

What exactly above error and how to fix it?

  1. This server does not serve auth.my.com
    What exactly auth.mydomain.com do and how to fix it?

  2. 2020-04-27 20:52:35.141 SEVERE: [20] RetryStrategy$TaskRunner.run#198: org.jivesoftware.smack.SmackException$AlreadyLoggedInException: Client is already logged in
    org.jivesoftware.smack.SmackException$AlreadyLoggedInException: Client is already logged in
    at org.jivesoftware.smack.tcp.XMPPTCPConnection.throwAlreadyLoggedInExceptionIfAppropriate(XMPPTCPConnection.java:371)

What exactly above error signify?

Appreciate any help on above.

Regards,
Apitools

is this setup on 1 server?

  1. your jvb is trying to connect to prosody but it can’t. make sure the jvb can telnet to xmpp server on port 5222.
  2. That is your muc name, check on your prosody config
  3. usualy it will disappear when you restart the jvb (but i dont know what the meaning of the error)

Thanks I will check the config as you suggested. Also I am seeing another error not able to setup conference with 3 or more people

INFO: [26] Videobridge.createConference#319: create_conf, id=146d63604a921a0 gid=null logging=false
2020-04-28 11:20:27.078 INFO: [26] AbstractHealthCheckService.run#171: Performed a successful health check in PT0.048S. Sticky failure: false
2020-04-28 11:20:28.365 SEVERE: [35] ComponentMain.lambda$getConnectCallable$0#293: host-unknown, host:localhost, port:5347
org.xmpp.component.ComponentException: host-unknown
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:243)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:242)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:222)
at org.jitsi.meet.Comp

Can you please help? I already verified that process is running on port 5347 and telnet is working

the latest version of jitsi-meet will automatically using muc mode. in this mode, jvb connect to prosody via port 5222 not 5347.

If you dont mind, you can check this installation guide that I made:
https://gist.github.com/facsiaginsa/2b9f9dbd92c27642a44a8e49493f662f

Thanks a million however I am having everything on the same server. Is it possible to change the configuration to fix this problem or I need to do a installation from scrach?

You can still follow the config on that guide, no need to reinstall.i think

Sure will do hopefully I will be able to get it working :slight_smile: thanks amillion for your help

I managed to get it working on single server however the call quality is very poor, request your help…do I need to do any settings changes? I see bandwidth is not an issue as all the 4 members have high speed internet connection.

nice…

I cant help much with that, because many factor is causing bad quality video conference. But there is something you can edit in /etc/jitsi/meet/-config.js. search for parameter constraints (the default is commented), you can play with that to improve the user experience.