Errors after updating to last version (stable)

Hello

I update jitsi products to last version (stable)

when I launch a room on the browser (firefox 87.0[64bits]) I get some errors:

2021-04-08T20:37:57.640Z [JitsiMeetJS.js] : UnhandledError: AudioContext.createMediaStreamSource: Connecting AudioNodes from AudioContexts with different sample-rate is currently not supported. Script: null Line: null Column: null

2021-04-08T20:40:02.926Z [JitsiMeetJS.js] : UnhandledError: Ping timeout Script: null Line: null Column: null StackTrace: startInterval/this.intervalId</<@https://my-site.net/libs/lib-jitsi-meet.min.js?v=4628:10:145491

2021-04-08T20:40:02.928Z [modules/xmpp/strophe.ping.js] <startInterval/this.intervalId</<>: Ping timeout null

2021-04-08T20:42:30.617Z [JitsiMeetJS.js] : UnhandledError: This client does not support P2P connections Script: null Line: null Column: null StackTrace: ie.prototype._rejectIncomingCall@https://my-site.net/libs/lib-jitsi-meet.min.js?v=4628:10:62049

2021-04-08T20:42:38.345Z [modules/RTC/BridgeChannel.js] <_send>: Bridge Channel send: no opened channel.

do you have any idea where this could be coming from?

Thanks for your help.

How did you perform the update?

just by doing the following instructions:

sudo apt-get update
sudo apt-get upgrade

ckwsoft,

I did as much the same as yourself (apt update && apt dist-upgrade -y) to my server today and had no issues. My server was set up in late January. If your Jitsi server is older, there might be a difference in config files ?

Please look though the log files and look for error messages, maybe you can find something there.

thank you for your answer,

I set up my server in 2019

indeed after the last update I had a problem with the prosody service that doesn’t start anymore because of the prosody.cfg.lua file that was not up to date so I updated it manually.

I have to look at which log file?

prosody.log, jicofo.log or jvb.log

thanks

this is what I see in the log file when I run the following command:

sudo tail -F /var/log/jitsi/jvb.log

2021-04-10 17:13:36.569 INFO: [18] VideobridgeExpireThread.expire#144: Running expire()
2021-04-10 17:13:36.786 SEVERE: [20] AbstractHealthCheckService.run#185: Health check failed in PT0.000042S:
java.lang.Exception: Failed to bind single-port
at org.jitsi.videobridge.health.Health.performCheck(Health.java:161)
at org.jitsi.health.AbstractHealthCheckService.run(AbstractHealthCheckService.kt:155)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.run(RecurringRunnableExecutor.java:216)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.runInThread(RecurringRunnableExecutor.java:292)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.access$000(RecurringRunnableExecutor.java:36)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor$1.run(RecurringRunnableExecutor.java:328)
2021-04-10 17:13:39.832 INFO: [24] HealthChecker.run#170: Performed a successful health check in PT0.000034S. Sticky failure: false
2021-04-10 17:13:46.786 SEVERE: [20] AbstractHealthCheckService.run#185: Health check failed in PT0.000065S:
java.lang.Exception: Failed to bind single-port
at org.jitsi.videobridge.health.Health.performCheck(Health.java:161)
at org.jitsi.health.AbstractHealthCheckService.run(AbstractHealthCheckService.kt:155)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.run(RecurringRunnableExecutor.java:216)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.runInThread(RecurringRunnableExecutor.java:292)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.access$000(RecurringRunnableExecutor.java:36)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor$1.run(RecurringRunnableExecutor.java:328)

Maybe kill all java processes and restart jicofo and jvb, or you have another process binding to port 10000?

Hello @damencho

thank you for your answer.

I just did what you suggested and I don’t have the error message in the jvb.log file anymore :ok_hand: :grinning:

on the other hand I still see the errors in the firefox console

Firefox can’t connect to the server at wss://my-site.net/colibri-ws/default-id/17e65f96ef28aa7c/5f28b128?pwd=66vntmsgsjeiq0qp34b3qil8k8. BridgeChannel.js:86:19

did I forget to do something?

do you have any idea where it could come from?

thank you in advance for your help

Missing the colibri-ws setting in nginx config, or jvb with not enabled websockets not listening on port 9090.

I use the apache2 server,
and here is the content of the file /etc/jitsi/videobridge/jvb.conf

jvb.conf

I added these lines of code in the *virtualHost :443

ProxyPreserveHost on
ProxyPass /http-bind http://localhost:5280/http-bind
ProxyPassReverse /http-bind http://localhost:5280/http-bind
ProxyPass /xmpp-websocket ws://localhost:5280/xmpp-websocket
ProxyPassReverse /xmpp-websocket ws://localhost:5280/xmpp-websocket
ProxyPass /colibri-ws/default-id ws://localhost:9090/colibri-ws/default-id
ProxyPassReverse /colibri-ws/default-id ws://localhost:9090/colibri-ws/default-id

but nothing to change I still have the errors

Check your apache enabled modules jitsi-meet/jitsi-meet-web-config.postinst at fd4819aeca47162c7c2cb9c79b01a4d0b117b3b1 · jitsi/jitsi-meet · GitHub

Hi @damencho

here is the list of modules loaded in the apache server (sudo apachectl -M):

Are those I showed you loaded?

yes, when I run the command “sudo apachectl -m” it returns the list of my modules loaded in the apache server and I see that the modules “rewrite ssl headers proxy_http proxy_wstunnel include” are well loaded

So it is not apache. Do you see jvb listening on localhost port 9090?

I don’t know how to see if jvb is listening to port 9090 but when I run the command lsof -i :9090 OR netstat -tln | grep 9090, it returns this:

netsat -anp | grep 9090 … but I guess this works …
maybe check jvb logs for errors when you see the error in the web browser console?

when I run the command “netstat -anp | grep 9090” it returns this:

tcp6 0 0 :::9090 :::* LISTEN 1/systemd

when I see the error in the browser console, this is what I have in the jvb.log file

jvb.log.txt (35.0 KB)

it seems to me there is no error, but maybe I’m wrong