[Error] XMLHttpRequest cannot load <OUR BOSH URL> due to access control checks


Thank you so much for your amazing work! I hope you’ll be able to assist me.

We’ve done extensive testing after installing Jitsi and everything is working 100%, except using Jitsi in Safari on an iPhone, over a 4G or 5G network.
Everything is 100% when we switch the same iPhone to WiFi.

We get this error in Safari’s console on the iPhone:

[Error] XMLHttpRequest cannot load due to access control checks.
d (lib-jitsi-meet.min.js:2:669386)
_processRequest (lib-jitsi-meet.min.js:2:669520)
_throttledRequestHandler (lib-jitsi-meet.min.js:2:671402)
_onIdle (lib-jitsi-meet.min.js:2:666243)
_onIdle (lib-jitsi-meet.min.js:2:655823)

We believe the error might be caused by network throttling on the 4G or 5G network?
We reviewed all the Access-Control-Allow-Origin posts and don’t think this is relevant to our problem.

We tested 4 different iPhones - same behavior.
The same test cases are working on Android devices.

Any help will be highly appreciated.

Thank you so much.
Kind regards


That’s unlikely, the BOSH endpoint doesn’t generate that much traffic.

Hi @saghul

Thank you for your reply.
Do you know what “access control checks” are being done in the "_throttledRequestHandler (lib-jitsi-meet.min.js) ?

It is really strange that we only get this error on Safari, on an iPhone (various models), only on a mobile network. It is working well as soon as we switch to a WiFi network. I know you can configure networks to be “metered” networks ie. pay per MB.
This is the only obvious difference that I can spot.

Please let me know if you can think of anything to investigate, else I may do a total clean re-install.

This code is in a dependency we use it is not in lib-jitsi-meet code:

Hi @damencho

Thank you for the reply. I also reviewed the .js code.

It must be one of the layers higher up that gives the “[Error] XMLHttpRequest cannot load due to access control checks.” error message, which we can see in the Safari console (only when on a mobile network).

Given that no one seems to be getting this exact error, I’ll do a full re-deployment and re-test end-to-end.
I must be missing a config setting somewhere.

Do you reproduce the same on meet.jit.si?

Hi @damencho

Good point - I’ll try this on our server overnight when I can play with the config.

Nope, just test it on meet.jit.si do you reproduce it there.

Apologies, thought you suggested to change the BOSH URL.

I’ve done a test on meet.jit.si - it is working 100%

I’ll do a full re-deployment on my server. I must have done something wrong.
I’ve upgraded several versions over the years and I think that one of my .js files is out of date.

Thank you for your help.