Error with Letsencrypt

When I run the script /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh I obtain the following errors:

Failed authorization procedure. subdomain.mydomain.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from https://subdomain.mydomain.com/.well-known/acme-challenge/g0MdsK-rcXXSWW4gTFw_Sp197GTWXJdNx5BkFK39M_U [94.247.177.195]: “\n\n <base href=”/" />\n\n <link rel=“stylesheet” href=“css/all.css”/>\n Jitsi Meet\n<meta propert"

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: subdomain.mydomain.com
    Type: unauthorized
    Detail: Invalid response from
    https://subdomain.mydomain.com/.well-known/acme-challenge/g0MdsK-rcXXSWW4gTFw_Sp197GTWXJdNx5BkFK39M_U
    [94.247.177.195]: “\n\n <base href=”/" />\n\n

    \n Jitsi Meet\n<meta propert"

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address.

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

Do you have this in your nginx config: jitsi-meet/jitsi-meet.example at e803e8cfd9f87ed4ac02098de74da9f0c5457ff7 · jitsi/jitsi-meet · GitHub ?

I am using a VPS server with plesk, can I add that code to the additional gninx configuration or in which file should I add it?

When I add this lines to my nginx config I obtain this error:

Configuración de nginx inválida: nginx: [emerg] duplicate location “/.well-known/acme-challenge/” in /var/www/vhosts/system/subdomain.mydomain.com/conf/vhost_nginx.conf:22 nginx: configuration file /etc/nginx/nginx.conf test failed

Normally let’s encrypt requests come on http port … maybe add those rules and for the https vhost and try …