Error when i install jitsi in ubuntu?

Setting up jitsi-meet-web (1.0.4074-1) …
Setting up jitsi-meet-prosody (1.0.4074-1) …
The given hostname does not exist in the config
dpkg: error processing package jitsi-meet-prosody (–configure):
installed jitsi-meet-prosody package post-installation script subprocess returned error exit status 1
Setting up jicofo (1.0-567-1) …
useradd: warning: the home directory already exists.
Not copying any file from skel directory into it.
dpkg: dependency problems prevent configuration of jitsi-meet:
jitsi-meet depends on jitsi-meet-prosody (= 1.0.4074-1); however:
Package jitsi-meet-prosody is not configured yet.

dpkg: error processing package jitsi-meet (–configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Processing triggers for ureadahead (0.100.0-21) …
Processing triggers for systemd (237-3ubuntu10.39) …
Errors were encountered while processing:
jitsi-meet-prosody
jitsi-meet
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hi Abeer. Did you have a previous installation of Jitsi before this?

No it is first time for me!

image001.jpg

This error looks like it is being caused when prosody is trying to generate certificates. If you open /etc/prosody/prosody.cfg.lua does it include the line:

Include "conf.d/*.cfg.lua"

If not, add it manually to the bottom and restart prosody with sudo systemctl restart prosody. Then reinstall jitsi-meet with sudo apt reinstall jitsi-meet.

Also check that /etc/hosts and /etc/hostname are filled out correctly as shown in the quick start guide and test it with hostname -f. I think it is unlikely to be that though.

Let me know how you get on.

127.0.0.1 JitsiFHV.lu.se

130.235.151.100 lrtc726.srv.lu.se

The following lines are desirable for IPv6 capable hosts

::1 localhost ip6-localhost ip6-loopback

ff02::1 ip6-allnodes

ff02::2 ip6-allrouters

image001.jpg

it is saying invalid operation reinstall. I also used sudo apt-get cpufrequtils, thought it maybe of any help

That is interesting! I spun up both base instances of Ubuntu 18.04 LTS and Ubuntu 20.04 LTS and reinstall worked fine for me.

$ apt --help

apt 2.0.2 (amd64)
Usage: apt [options] command

apt is a commandline package manager and provides commands for
searching and managing as well as querying information about packages.
It provides the same functionality as the specialized APT tools,
like apt-get and apt-cache, but enables options more suitable for
interactive use by default.

Most used commands:
  list - list packages based on package names
  search - search in package descriptions
  show - show package details
  install - install packages
  reinstall - reinstall packages
  remove - remove packages
  autoremove - Remove automatically all unused packages
  update - update list of available packages
  upgrade - upgrade the system by installing/upgrading packages
  full-upgrade - upgrade the system by removing/installing/upgrading packages
  edit-sources - edit the source information file
  satisfy - satisfy dependency strings

See apt(8) for more information about the available commands.
Configuration options and syntax is detailed in apt.conf(5).
Information about how to configure sources can be found in sources.list(5).
Package and version choices can be expressed via apt_preferences(5).
Security details are available in apt-secure(8).
                                        This APT has Super Cow Powers.

Does apt update work for you? What version of Ubuntu are you using?

i am using 16.04

Hi,

I just went over the installation process again and it did not give me any error. My question though is this, how am I going to access the application since I only put in my IP address and not setup FQDN?

Great! Are you intending to use Jitsi Meet just on your local network, or on the internet?

On the internet!

/Abeer

image001.jpg

I don’t know how to fix this,

my idea when we are going to surf to services should be called JitsiFHV.lu.se, and what I did I have fixed the certtifikat for this name.

When I install jitsi and enter JitsiFHV.lu.se in the install got wrong.

I don’t know how to combine JitsiFHV.lu.se with hosts file that looks like this:

127.0.0.1 localhost

130.235.151.100 lrtc726.srv.lu.se

The following lines are desirable for IPv6 capable hosts

:: 1 localhost ip6-localhost ip6 loopback

ff02 :: 1 ip6 allnodes

ff02 :: 2 ip6 all-routers

image001.jpg

On the internet. I can already access it but it shows grey screen and has the interfaceConfig error on the console

    at Object.<anonymous> (app.bundle.min.js:1)
    at n (app.bundle.min.js:1)
    at Object.<anonymous> (app.bundle.min.js:16)
    at n (app.bundle.min.js:1)
    at Object.<anonymous> (app.bundle.min.js:1)
    at n (app.bundle.min.js:1)
    at Object.<anonymous> (app.bundle.min.js:1)
    at n (app.bundle.min.js:1)
    at Object.<anonymous> (app.bundle.min.js:1)
    at n (app.bundle.min.js:1)
    at Object.<anonymous> (app.bundle.min.js:24)
    at n (app.bundle.min.js:1)
    at Object.<anonymous> (app.bundle.min.js:29)
    at n (app.bundle.min.js:1)
    at Object.<anonymous> (app.bundle.min.js:24)
    at n (app.bundle.min.js:1)
    at Object.<anonymous> (app.bundle.min.js:63)
    at n (app.bundle.min.js:1)
    at Object.<anonymous> (app.bundle.min.js:54)
    at Object.<anonymous> (app.bundle.min.js:54)
    at n (app.bundle.min.js:1)
    at Object.<anonymous> (app.bundle.min.js:54)
    at Object.<anonymous> (app.bundle.min.js:54)
    at n (app.bundle.min.js:1)
    at Object.<anonymous> (app.bundle.min.js:126)
    at Object.<anonymous> (app.bundle.min.js:126)
    at n (app.bundle.min.js:1)
    at Module.<anonymous> (app.bundle.min.js:222)
    at n (app.bundle.min.js:1)
    at app.bundle.min.js:1
    at app.bundle.min.js:1 ```

Did you check the /etc/prosody/prosody.cfg.lua? What did you find?

Include “conf.d/*.cfg.lua”

Hi,

Thank you for responding. Yes, I checked prosody.cfg.lua and saw the include line. Im not sure though what to do in etc/hosts and etc/hostname.

Note: I only used IP and not FQDN

ok now i will install jitsi and use IP,what do you recommend using nginx or apache because i will need shibboleth?

I’d probably need to see a bit more of the log, I’m wondering if you have a security error as well. This can be caused if you’re not using HTTPS. I’ve also seen attempts to incorporate Jitsi into other websites using iframes, which will fail in a similar way.

For LetsEncrypt I’m pretty sure you need a domain name (I’m open to being proved wrong.) If you have a static IP address and a domain name, then just add an A record.

If you are using a NAT router check the instructions in the quick install guide. Make sure you know how to security harden your setup and you monitor /log/nginx/access.log for any port scanning and hacking attempts.

Gotcha. Just to confirm, letsEncrypt is still optional right? For now I just have an IP address (that is what i put on the installation), and that is what I’ll add in both etc/host and etc/hostname?

i will install on your server with your logo icon and your branding at just 60$ .
If any one needed complete installation with customization and server at cheap price ping me. I will only charge 60$ for all these.
ping me on skype my skype id is shashank.singh451. you can whatsapp me at +919953026723