Error Jibri when starts record

Hi,
I have a vm with jitsi installed that works fine. I have installed Jibri on another server for the recordings but I cannot get it to work well.
First the recording has stopped warning appears and then recording failed to start.

The SEVERE error I have on the Jibri server is the following:
2020-05-18 11:30:35.658 INFO: [34] org.jitsi.jibri.api.xmpp.XmppApi.handleJibriIq() Received JibriIq from environment [MucClient id=meet hostname=meet]
2020-05-18 11:30:35.658 INFO: [34] org.jitsi.jibri.api.xmpp.XmppApi.handleStartJibriIq() Received start request
2020-05-18 11:30:35.659 INFO: [34] org.jitsi.jibri.api.xmpp.XmppApi.handleStartJibriIq() Sending ‘pending’ response to start IQ
2020-05-18 11:30:35.659 INFO: [36] org.jitsi.jibri.api.xmpp.XmppApi.run() Starting service
2020-05-18 11:30:35.659 SEVERE: [36] org.jitsi.jibri.api.xmpp.XmppApi.run() Error starting Jibri service : org.jitsi.jibri.util.CallUrlInfoFromJidException: Unable to extract call url info from Jid alberto@conference.meet.meytel.cloud (stripFromRoomDomain = conference.meet.meytel.cloud, xmppDomain = meet.meytel.cloud) with stack:
org.jitsi.jibri.util.XmppUtilsKt.getCallUrlInfoFromJid(XmppUtils.kt:47)
org.jitsi.jibri.api.xmpp.XmppApi.handleStartService(XmppApi.kt:271)
org.jitsi.jibri.api.xmpp.XmppApi.access$handleStartService(XmppApi.kt:67)
org.jitsi.jibri.api.xmpp.XmppApi$handleStartJibriIq$1.run(XmppApi.kt:195)
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
java.util.concurrent.FutureTask.run(FutureTask.java:266)
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
java.lang.Thread.run(Thread.java:748)

Could you help me?

Thank’s

I’ve already solved it.
Thank you

hi! how u solved it?

Hi, @grgorianaleksandr yes, is working fine.
Thanks

but how did you fix this error? can you tell me

Hi @grgorianaleksandr, in my case, the problem was the DNS resolution. Adding in the /etc/hosts the following FDQN: conference, auth, jitsi-videobridge and internal pointing to the internal IP of the jitsi server was enough.
I added all the fqdn contained in the jibri config.json file.

thanks for your reply!
could you please show by example what and how you entered in /etc/hosts

my config.json:

"xmpp_server_hosts": [
                "my-jitsi.com"
            ],
            "xmpp_domain": "my-jitsi.com",
            "control_login": {
                "domain": "auth.my-jitsi.com",
                "username": "jibri",
                "password": "jibripass"
            },
            "control_muc": {
                "domain": "internal.auth.my-jitsi.com",
                "room_name": "JibriBrewery",
                "nickname": "jibri"
            },
            "call_login": {
                "domain": "recorder.my-jitsi.com",
                "username": "recorder",
                "password": "recorderpass"

according to your advice, I wrote in /etc/hosts on my jibri server:

127.0.0.1 localhost 
10.1.12.23 my-jitsi.com recorder.my-jitsi.com internal.auth.my-jitsi.com auth.my-jitsi.com

(10.1.12.23 - internal IP of my jitsi server)

it is right /etc/hosts?

No need to internal addresses, only my-jitsi.com

127.0.0.1 localhost
10.1.12.23 my-jitsi.com
1 Like

Hello,
recorder.my-jitsi.com must be in 127.0.0.1 localhost recorder.my-jitsi.com, recorder is FQDN for jibri.

Point to your jitsi server: conference.my-jitsi.com internal.auth.my-jitsi.com auth.my-jitsi.com jitsi-videobridge.my-jitsi.com my-jitsi.com.

Also you have add recorder.my-jitsi.com in /etc/hosts to the jitsi server point to IP of jibri server.

1 Like