Error installing webpack [SOLVED]


#1

Hello,

I’m not sure it’s the right place but it seems webpack is jitsi related.

I’m not able to install it.
It seems options -std=gnu++0x and -std=c++0x are not understood.
It’s probably because I use Openbsd and there’s something to do.
I saw this post


Where someone says
Try building with make CXX=eg++ CXX.host=eg++ CXX.target=eg++.
But I’m not a developper and don’t know where to start.

gyp verb which succeeded for gmake /usr/local/bin/gmake
gmake: Entering directory ‘/usr/local/jitsi-meet/node_modules/node-sass/build’
gyp g++ ‘-DNODE_GYP_MODULE_NAME=libsass’ ‘-DUSING_UV_SHARED=1’ ‘-DUSING_V8_SHARED=1’ ‘-DV8_DEPRECATION_WARNINGS=1’ ‘-D_LARGEFILE_SOURCE’ ‘-D_FILE_OFFSET_BITS=64’ ‘-DLIBSASS_VERSION=“3.5.2”’ -I/root/.node-gyp/8.12.0/include/node -I/root/.node-gyp/8.12.0/src -I/root/.node-gyp/8.12.0/deps/uv/include -I/root/.node-gyp/8.12.0/deps/v8/include -I…/src/libsass/include -fPIC -pthread -Wall -Wextra -Wno-unused-parameter -m64 -I/usr/local/include -O3 -fno-omit-frame-pointer -std=gnu++0x -std=c++0x -fexceptions -frtti -MMD -MF ./Release/.deps/Release/obj.target/libsass/src/libsass/src/ast.o.d.raw -c -o Release/obj.target/libsass/src/libsass/src/ast.o …/src/libsass/src/ast.cpp
info spawn gmake
gyp info spawn args [ ‘V=1’, ‘BUILDTYPE=Release’, ‘-C’, ‘build’ ]
cc1plus: error: unrecognized command line option “-std=gnu++0x”
cc1plus: error: unrecognized command line option “-std=c++0x”
gmake: *** [src/libsass.target.mk:146: Release/obj.target/libsass/src/libsass/src/ast.o] Error 1
gmake: Leaving directory ‘/usr/local/jitsi-meet/node_modules/node-sass/build’
gyp ERR! build error
gyp ERR! stack Error: gmake failed with exit code: 2
gyp ERR! stack at ChildProcess.onExit (/usr/local/jitsi-meet/node_modules/node-gyp/lib/build.js:258:23)
gyp ERR! stack at emitTwo (events.js:126:13)
gyp ERR! stack at ChildProcess.emit (events.js:214:7)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:198:12)
gyp ERR! System OpenBSD 6.4
gyp ERR! command “/usr/local/bin/node” “/usr/local/jitsi-meet/node_modules/node-gyp/bin/node-gyp.js” “rebuild” “–verbose” “–libsass_ext=” “–libsass_cflags=” “–libsass_ldflags=” “–libsass_library=”
gyp ERR! cwd /usr/local/jitsi-meet/node_modules/node-sass
gyp ERR! node -v v8.12.0
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok
Build failed with error code: 1
npm WARN @atlaskit/flag@6.1.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/icon@7.1.0 requires a peer of react@^15.3.2 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/theme@2.4.1 requires a peer of react@15.6.0 - 16.2.0 but none is installed. You must install peer dependencies yourself.
npm WARN styled-components@1.4.6 requires a peer of react@^0.14.0 || ^15.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/inline-dialog@5.3.0 requires a peer of react@15.6.0 - 16.2.0 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/inline-dialog@5.3.0 requires a peer of react-dom@15.6.0 - 16.2.0 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/layer@2.9.1 requires a peer of react@15.6.0 - 16.2.0 but none is installed. You must install peer dependencies yourself.
npm WARN @atlaskit/theme@2.4.1 requires a peer of react@15.6.0 - 16.2.0 but none is installed. You must install peer dependencies yourself.
npm WARN styled-components@1.4.6 requires a peer of react@^0.14.0 || ^15.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/watchpack/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“openbsd”,“arch”:“x64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/sane/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“openbsd”,“arch”:“x64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“openbsd”,“arch”:“x64”})

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! node-sass@4.8.3 postinstall: node scripts/build.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-sass@4.8.3 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2018-11-03T12_07_38_402Z-debug.log


#2

The solution was to set the environnement variables
export CC=/usr/bin/clang
export CXX=/usr/bin/clang++