Error in the live transmission of Jitsi Meet via PeerTube

Hi, when I create a live stream in jitsi meet using the RTMP URL data from the peertube instance, I get an error. It tells me that the stream could not be started. However, if I try to start a stream with the OBS software, the peertube stream works without problems. Attached are screenshots of the peertube and jitsi configurations, plus the URL to the peertube documentation for creating live streams. I hope you can help me. Thanks

https://docs.joinpeertube.org/use-create-upload-video?id=publish-a-live-in-peertube-gt-v3
https://docs.joinpeertube.org/use-create-upload-video?id=with-jitsi-meet

jitsi meet

I attach in this post, the data of the peertube rtmp address.
peertube

Is this your own deployment or the public Jitsi server?

The problem occurs on the public jitsi server, but also on several public jitsi instances according to the listing Community-run instances · Jitsi Meet Handbook

I have not yet found a jitsi instance that allows to stream to peertube, by logic I understand that it is a jitsi problem, because the OBS software streams to peertube without problems. Regards

If ffmpeg can stream to peertube than Jitsi too

I have not tried with ffmpeg, I have tried with OBS and the transmission to peertube works without problems.

Could you test with jitsi to peertube please, to see if the same thing happens to you. Thanks.

Can you send me the RTMP push address as a private message?

It seems working

Yes, I see it. could you pass me your url of jitsi meet that you have tried? how did you write the url in jitsi? Thanks

I wrote the whole path as stream key

rtmp://domain.com:1936/live/stream-code

JMS is our company server which is up-to-date stable Jitsi

Yesterday afternoon I tried jitsi meet and it worked, I wonder why the previous days it didn’t work.

Greetings

probably your server was down, or transcoding was enabled

Unfortunately I have a similar problem. I can stream to my own PeerTube instance via ffmpeg directly or via OBS. I can also stream from the Jitsi public instance. Unfortunately I can’t stream from my own Jitsi instance to my PeerTube instance. I used the URL format shared above rtmp://domain.com:1935/live/stream-code on all occasions. I relied on Self-Hosting Guide - Docker · Jitsi Meet Handbook and as far as I can tell worked well so far. Suggestions appreciated.

Do you have some Jibri logs you can attach?

I’m sure I can do that @bbaldino . I tried docker logs docker-jitsi-meet_jvb_1 but didn’t see anything useful there. What command should I run to share the most useful logs to debug this specific situation?

Getting this still despite the URL working with Obs. Is there something to enable on the Jitsi Docker configuration to enable streaming to custom instances?

image

I checked logs via Docker on all 4 containers but nothing our of the ordinary. What I see though client side is Uncaught (in promise) iq id="e5ce0dd9-1153-4b73-8645-d2262cbdde13:sendIQ" to="c43327ff-81d8-4433-8dbe-…8dc@meet.jitsi/Sf0qyy7G" type="error" xmlns="jabber:client" from="roman@muc.meet.jitsi/focus"

I updated Jitsi to the latest stable and still have the problem. Everything works (voice, video, chat, even the blurred background) but somehow not live streaming.

I tried again from the official Jitsi instance and it also works so I’m 100% sure the problem doesn’t come from PeerTube or my streaming URL, otherwise it wouldn’t work from the official Jitsi server.

I tried community ran ones e.g. jitsi.ssps.cz, jitsi-1.belnet.be, allo.bim.land and another and none of them worked. I gave up going further down the list Community-run instances · Jitsi Meet Handbook at that point.

That leads me to believe that there is some configuration difference. Maybe it’s from Self-Hosting Guide - Docker · Jitsi Meet Handbook or self-hosting in general but this can’t be a coincidence.

Could it be related to jibri specifcally as asked by @bbaldino? I assumed it was started by default due to the button being available in the web interface but this line of the documentation If you want to use jibri too, first configure a host as described in JItsi BRoadcasting Infrastructure configuration section and then run Docker Compose and the lack of Jibri appearing in docker ps makes me think it is not.

Well I enabled Jibri as suggested above. I updated my kernel to have the audio loopback on the host. I rebooted and had the module properly loaded verified via lsmod | grep snd_aloop. I have Jibri running in Docker and see no error in the log. Unfortunately… still (!) the same error.

Need Jibri logs to help debug this.

Here are the logs jibrilogs.txt · GitHub

Activating streaming seems to make no changes in logs.

It looks like that Jibri is never even seeing a request, so I suspect it’s something about Jicofo not seeing it. Do you have Jicofo logs?