Error in jitsi-meet-prosody.postinst

It looks like there is a small typo in jitsi-meet-prosody.postinst:

    # For those deployments that don't have the config in the jitsi-meet prosody config add the new jaas file
    if [ ! -f $JAAS_HOST_CONFIG ] && ! grep -q "VirtualHost \"jigasi.meet.jitsi\"" $PROSODY_HOST_CONFIG; then
        PROSODY_CONFIG_PRESENT="false"
        cp /usr/share/jitsi-meet-prosody/jaas.cfg.lua $JAAS_HOST_CONFIG
        sed -i "s/jitmeet.example.com/$JVB_HOSTNAME/g" $JAAS_HOST_CONFIG
    fi

This ends up with /etc/prosody/conf.d/jaas.cfg.lua that has the following inside:

VirtualHost “jigasi.meet.jitsi”

The domain name is not properly replaced, it doesn’t work and there is error in prosody. It should either be:

sed -i "s/meet.jitsi/$JVB_HOSTNAME/…

or the template should be with “jitmeet.example.com” instead of “meet.jitsi”.

Sorry if this has already been reported.

2 Likes

What is the error?
The intention is that this is never changed accross deployments: jitsi-meet/jaas.cfg.lua at 090433b6e86adedb0b8591e728dca403ad3d491e · jitsi/jitsi-meet · GitHub

So we can point jaas jigasi there. The authorization is done using jwt the only replacement should happen here: jitsi-meet/jaas.cfg.lua at 090433b6e86adedb0b8591e728dca403ad3d491e · jitsi/jitsi-meet · GitHub as this is part of the authorization .

No certificate present in SSL/TLS configuration for jigasi.meet.jitsi

in /var/log/prosody/

My mistake, if that was the intent, to have the host explicitly as jigasi.meet.jitsi, sorry. :slight_smile:

But what about the SSLs that it’s complaining in the logs?

That should be a warning, not an error, right?
The certificates for non of the virtual host is actually used and all a self signed. The connection is done using http for the bosh and websocket on localhost.
The only exception is maybe the vhosts for jibri and jvb where those components connect on 5222…

And if I remember correctly some of those warnings go away if you disable the https thingy with:

Yes, you are right, it’s just a warning - sorry for the noise.

No worries :slight_smile: