Error during running ios script

I am trying to build jisti SDK
I am follwoing Instructions from building it yourself guideline

here are the logs

Can you tell how to fix it?

+ BUNDLE_FILE=/Users/kamil/Library/Developer/Xcode/DerivedData/jitsi-meet-ewvjobzivboiwpbasxaxtnvtdcoy/Build/Intermediates.noindex/ArchiveIntermediates/JitsiMeetSDK/BuildProductsPath/Release-iphonesimulator/JitsiMeetSDK.framework/main.jsbundle
+ node --max_old_space_size=4096 /Users/kamil/Apps/jitsi-meet/node_modules/react-native/cli.js bundle --entry-file index.ios.js --platform ios --dev false --reset-cache --bundle-output /Users/kamil/Library/Developer/Xcode/DerivedData/jitsi-meet-ewvjobzivboiwpbasxaxtnvtdcoy/Build/Intermediates.noindex/ArchiveIntermediates/JitsiMeetSDK/BuildProductsPath/Release-iphonesimulator/JitsiMeetSDK.framework/main.jsbundle --assets-dest /Users/kamil/Library/Developer/Xcode/DerivedData/jitsi-meet-ewvjobzivboiwpbasxaxtnvtdcoy/Build/Intermediates.noindex/ArchiveIntermediates/JitsiMeetSDK/BuildProductsPath/Release-iphonesimulator/JitsiMeetSDK.framework
warning: the transform cache was reset.
node:events:342
      throw er; // Unhandled 'error' event
      ^

Error: EMFILE: too many open files, watch
    at FSEvent.FSWatcher._handle.onchange (node:internal/fs/watchers:204:21)
Emitted 'error' event on NodeWatcher instance at:
    at NodeWatcher.checkedEmitError (/Users/kamil/Apps/jitsi-meet/node_modules/sane/src/node_watcher.js:143:12)
    at FSWatcher.emit (node:events:365:28)
    at FSEvent.FSWatcher._handle.onchange (node:internal/fs/watchers:210:12) {
  errno: -24,
  syscall: 'watch',
  code: 'EMFILE',
  filename: null
}
+ [[ false != true ]]
+ [[ ! -f /Users/kamil/Library/Developer/Xcode/DerivedData/jitsi-meet-ewvjobzivboiwpbasxaxtnvtdcoy/Build/Intermediates.noindex/ArchiveIntermediates/JitsiMeetSDK/BuildProductsPath/Release-iphonesimulator/JitsiMeetSDK.framework/main.jsbundle ]]
+ echo 'error: File /Users/kamil/Library/Developer/Xcode/DerivedData/jitsi-meet-ewvjobzivboiwpbasxaxtnvtdcoy/Build/Intermediates.noindex/ArchiveIntermediates/JitsiMeetSDK/BuildProductsPath/Release-iphonesimulator/JitsiMeetSDK.framework/main.jsbundle does not exist. This must be a bug with'
error: File /Users/kamil/Library/Developer/Xcode/DerivedData/jitsi-meet-ewvjobzivboiwpbasxaxtnvtdcoy/Build/Intermediates.noindex/ArchiveIntermediates/JitsiMeetSDK/BuildProductsPath/Release-iphonesimulator/JitsiMeetSDK.framework/main.jsbundle does not exist. This must be a bug with
+ echo 'React Native, please report it here: https://github.com/facebook/react-native/issues'
React Native, please report it here: https://github.com/facebook/react-native/issues
+ exit 2

** ARCHIVE FAILED **


The following build commands failed:
	PhaseScriptExecution Package\ React\ bundle /Users/kamil/Library/Developer/Xcode/DerivedData/jitsi-meet-ewvjobzivboiwpbasxaxtnvtdcoy/Build/Intermediates.noindex/ArchiveIntermediates/JitsiMeetSDK/IntermediateBuildFilesPath/sdk.build/Release-iphonesimulator/JitsiMeetSDK.build/Script-0BCA49651EC4B77500B793EE.sh
(1 failure)
1 Like

npm 7.12.1
node v16.1.0
xcode 12.4
cocoapods 1.10.1

1 Like

Same issue here, does anyone know how to fix it? This is extremely important :slight_smile:

Please help me. Iā€™m facing the same issue.
The mobile apps version jitsi-meet-ios-21.6.0
npm 8.1.2
node v16.13.2
xcode 12.4
cocoapods 1.11.2

Does anyone know how to fix it? Please help me.