Error during installation

Hi all
I am facing a weird error since last full week. During installation jitsi wont ask me to add the hostname and skips direcgtly on the ssl certificate step. After that at the end ouputs the error-

Processing triggers for libc-bin (2.31-0ubuntu9) ...
Errors encountered while processing
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can anyone pls help me out in this. I am still learning the application.
@damencho i’v been following you few suggestions regarding the same on several posts.
I believe that i am not able to uninstall jitsi configs completely from my system. Maybe thats why jitsi is picking up the hostname from somewhere. Please let me know what can be issue here.
Kind Regards

Here is the output i get in the terminal

useradd: warning: the home directory /usr/share/jitsi-videobridge already exists.
useradd: Not copying any file from skel directory into it.
* Applying /etc/sysctl.d/10-console-messages.conf ...
kernel.printk = 4 4 1 7
* Applying /etc/sysctl.d/10-ipv6-privacy.conf ...
net.ipv6.conf.all.use_tempaddr = 2
net.ipv6.conf.default.use_tempaddr = 2
* Applying /etc/sysctl.d/10-kernel-hardening.conf ...
kernel.kptr_restrict = 1
* Applying /etc/sysctl.d/10-link-restrictions.conf ...
fs.protected_hardlinks = 1
fs.protected_symlinks = 1
* Applying /etc/sysctl.d/10-magic-sysrq.conf ...
kernel.sysrq = 176
* Applying /etc/sysctl.d/10-network-security.conf ...
net.ipv4.conf.default.rp_filter = 2
net.ipv4.conf.all.rp_filter = 2
* Applying /etc/sysctl.d/10-ptrace.conf ...
kernel.yama.ptrace_scope = 1
* Applying /etc/sysctl.d/10-zeropage.conf ...
vm.mmap_min_addr = 65536
* Applying /etc/sysctl.d/20-jvb-udp-buffers.conf ...
net.core.rmem_max = 10485760
net.core.netdev_max_backlog = 100000
* Applying /usr/lib/sysctl.d/50-default.conf ...
net.ipv4.conf.default.promote_secondaries = 1
sysctl: setting key "net.ipv4.conf.all.promote_secondaries": Invalid argument
net.ipv4.ping_group_range = 0 2147483647
net.core.default_qdisc = fq_codel
fs.protected_regular = 1
fs.protected_fifos = 1
* Applying /usr/lib/sysctl.d/50-pid-max.conf ...
kernel.pid_max = 4194304
* Applying /etc/sysctl.d/99-cloudimg-ipv6.conf ...
net.ipv6.conf.all.use_tempaddr = 0
net.ipv6.conf.default.use_tempaddr = 0
* Applying /etc/sysctl.d/99-sysctl.conf ...
* Applying /usr/lib/sysctl.d/protect-links.conf ...
fs.protected_fifos = 1
fs.protected_hardlinks = 1
fs.protected_regular = 2
fs.protected_symlinks = 1
* Applying /etc/sysctl.conf ...
Created symlink /etc/systemd/system/ → /lib/systemd/system/jitsi-videobridge2.service.
Selecting previously unselected package jitsi-meet.
(Reading database ... 127494 files and directories currently installed.)
Preparing to unpack .../jitsi-meet_2.0.4857-1_all.deb ...
Unpacking jitsi-meet (2.0.4857-1) ...
Selecting previously unselected package lua-event:amd64.
Preparing to unpack .../lua-event_0.4.6-1build1_amd64.deb ...
Unpacking lua-event:amd64 (0.4.6-1build1) ...
Setting up lua5.2 (5.2.4-1.1build3) ...
update-alternatives: using /usr/bin/lua5.2 to provide /usr/bin/lua (lua-interpreter) in auto mode
update-alternatives: using /usr/bin/luac5.2 to provide /usr/bin/luac (lua-compiler) in auto mode
Setting up jitsi-meet-web-config (1.0.4289-1) ...
req: Use -help for summary.
dpkg: error processing package jitsi-meet-web-config (--configure):
 installed jitsi-meet-web-config package post-installation script subprocess returned error exit status 1
Setting up lua-socket:amd64 (3.0~rc1+git+ac3201d-4) ...
Setting up jicofo (1.0-612-1) ...
useradd: warning: the home directory /usr/share/jicofo already exists.
useradd: Not copying any file from skel directory into it.
Setting up lua-event:amd64 (0.4.6-1build1) ...
Setting up lua-expat:amd64 (1.3.0-4) ...
Setting up lua-filesystem:amd64 (1.7.0-2-1) ...
Setting up libidn11:amd64 (1.33-2.2ubuntu2) ...
Setting up lua-bitop:amd64 (1.0.2-5) ...
dpkg: dependency problems prevent configuration of jitsi-meet:
 jitsi-meet depends on jitsi-meet-web-config (= 1.0.4289-1); however:
  Package jitsi-meet-web-config is not configured yet.

dpkg: error processing package jitsi-meet (--configure):
 dependency problems - leaving unconfigured
Setting up jitsi-meet-web (1.0.4289-1) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Setting up lua-sec:amd64 (0.9-3) ...
Setting up prosody (0.11.4-1) ...
Adding user prosody to group ssl-cert
Setting up jitsi-meet-prosody (1.0.4289-1) ...
/var/lib/dpkg/info/jitsi-meet-prosody.postinst: line 104: [: /etc/prosody/conf.avail/: binary operator expected
The given hostname does not exist in the config
/var/lib/dpkg/info/jitsi-meet-prosody.postinst: line 138: [: /etc/prosody/conf.avail/: binary operator expected
/var/lib/dpkg/info/jitsi-meet-prosody.postinst: line 145: [: /var/lib/prosody/: binary operator expected
/var/lib/dpkg/info/jitsi-meet-prosody.postinst: line 171: [: /etc/prosody/conf.avail/: binary operator expected
/var/lib/dpkg/info/jitsi-meet-prosody.postinst: line 180: [: /var/lib/prosody/auth.: binary operator expected
Processing triggers for systemd (245.4-4ubuntu3.1) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for libc-bin (2.31-0ubuntu9) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Did you solve this problem ?
I have the same issue :confused:


@hkhait I uninstalled jitsi completely, and Nginx as well. Then reinstalled both again.
I guess in my machine video-bridge was not getting uninstalled properly from pervious installation, so maybe at installation it was picking up same hostname from old videobridge.
Just make sure you uninstalling “jitsi-videobridge2” and not “jitsi-videobridge”.
btw i created a script to uinstall jitsi completely:

apt-get --purge remove  jicofo jitsi-videobridge2 jitsi-videobridge && apt-get --purge remove jitsi-videobridge2 &&
apt-get autoclean && sudo apt-get --force-yes remove && 
apt-get --purge remove jitsi-meet-tokens &&
sudo apt-get install --reinstall dpkg && apt-get autoremove && apt-get autoclean &&  cd /var/lib/dpkg/info && sudo rm jitsi-meet-web-config.postinst && 
apt-get --purge remove jitsi-meet && 
apt-get purge && 
find / -type f -name '*jitsi*' -delete && 
find / -type f -name '*prosody*' -delete && 
find / -type f -name '*jigasi*' -delete && 
find / -type f -name '*jicofo*' -delete

after this i uninstalled Nginx and it worked for me.

1 Like

Thanks for the prompt response.
I actually have a problem with jitsi-meet-web-config package installation on a fresh docker machine.

/var/lib/dpkg/info/jitsi-meet-web-config.postinst: line 107: [: /etc/jitsi/meet/: binary operator expected

I think the problem is more related to the Debian docker image that I am using
I will keep digging

Problem solved.
It was very dumb actually.
never add many whitespaces in debconf-set-selections command :sweat_smile:

1 Like

oh. Great…very well then.