Error during install jitsi-meet-electron-2.8.8

Hello everyone,
I have tried to install jitsi-meet-electron-2.8.8 many times without luck, so could you provide me any link to follow it but with full steps, or can you tell me what is the problem.

The environment is as below:

Ubuntu 20.04.2 LTS

The steps to install are

 1  apt-get update
    2  apt-get upgrade
    3  hostname
    4  nano /etc/hosts
    5  udo ufw allow 80/tcp
    6  sudo ufw allow 80/tcp
    7  sudo ufw allow 443/tcp
    8  sudo ufw allow 4443/tcp
    9  sudo ufw allow 10000/udp
   10  sudo ufw status
   11  sudo ufw enable
   12  sudo ufw status
   13  sudo ufw allow ssh
   14  sudo ufw status
   15  wget https://download.jitsi.org/jitsi-key.gpg.key
   16  sudo apt-key add jitsi-key.gpg.key
   17  sudo apt update
   18  sudo apt install jitsi-meet
   19  sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

Now the jitsi-meet is working properly and we have performed many successful video meetings.

But I need to activate the remote control feature and I know it has security concerns, so I followed the installation guide as below:

After updating the repo to install nodejs v.12

apt -y install nodejs
apt -y  install gcc g++ make

Now it’s working properly

node --version
v12.22.2
npm --version
6.14.13
apt-get install libxtst-dev libpng++-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
libxtst-dev is already the newest version (2:1.2.3-1).
libpng++-dev is already the newest version (0.2.10-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Then I logged in to the directory and started the installation:

/home/administrator/jitsi-meet-electron-2.8.8# npm install

Finally I stuck at the below error:

mac-screen-capture-permissions@github:saghul/mac-screen-capture-permissions#14568eba35b0eebcf2b1b5c40d2c35fec3d88e8 /home/administrator/jitsi-meet-electron-2.8.8/node_modules/mac-screen-capture-permissions
> prebuild-install || node install.js

prebuild-install WARN install EACCES: permission denied, access '/root/.npm'

> robotjs@0.6.0 install /home/administrator/jitsi-meet-electron-2.8.8/node_modules/robotjs
> prebuild-install || node-gyp rebuild

prebuild-install WARN install EACCES: permission denied, access '/root/.npm'
gyp WARN EACCES current user ("administrator") does not have permission to access the dev dir "/root/.cache/node-gyp/
gyp WARN EACCES attempting to reinstall using temporary dev dir "/home/administrator/jitsi-meet-electron-2.8.8/node_mbotjs/.node-gyp"
gyp WARN install got an error, rolling back install
gyp WARN install got an error, rolling back install
gyp ERR! configure error
gyp ERR! stack Error: EACCES: permission denied, mkdir '/home/administrator/jitsi-meet-electron-2.8.8/node_modules/rode-gyp'
gyp ERR! System Linux 5.4.0-77-generic
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /home/administrator/jitsi-meet-electron-2.8.8/node_modules/robotjs
gyp ERR! node -v v12.22.2
gyp ERR! node-gyp -v v5.1.0
gyp ERR! not ok
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: dmg-license@1.0.8 (node_modules/dmg-license):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for dmg-license@1.0.8: wanted {"os":"darwin","arch(current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.12 (node_modules/watchpack/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.12: wanted {"os":"darwin","arch":urrent: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.0 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.0: wanted {"os":"darwin","arch":"rrent: {"os":"linux","arch":"x64"})

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! robotjs@0.6.0 install: `prebuild-install || node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the robotjs@0.6.0 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2021-07-18T09_04_45_643Z-debug.log

So, Kindly advise.

Looks like you’re building on a mac. What’s the OSX on the machine?

Hello Freddie,
Thanks for your reply,

I deployed in Linux Ubuntu 20.04.2 LTS.
I don’t use mac.

Regards,
Taha Gamil

Sorry, I’m probably just confused: are you building the electron app on the Ubuntu server hosting your Jitsi deployment?

Yes, I installed in my own Ubuntu server that hosted in my Datacenter.

There are two different things here - one, is your Jitsi meet (server) deployment. That’s what’s hosted in your Datacenter. The electron client is an app; you need to build that on a desktop machine (not on the server).

I understand you now, there is no installation required on the server-side for electron and its utilities So I should install the electron client app on my pc only.
thanks for your clarification.
Now I already installed it on my Windows PC, it’s a .exe file so How can I activate the remote control and file sharing features.
Is it via program files after the installation like : C:\Users\Zero\AppData\Local\Programs\jitsi-meet-electron.

Thanks for your great assistance.

If you’re using the generic Jitsi Meet Electron app, you won’t have access to remote control. Remote control was disabled for security reasons.

I know that as I can see from the release features, it’s applicable to enable it on my server when i change the value from false to true of the remote control, so I need to do it.

So, my question is can I enable it in the web version in the server side, so anyone join the meeting can use this feature, and on the client Pcs that installed the windows applications versions (jitsi-meet.exe).

Again, the electron app is not a server deployment. To enable remote control, you’ll need to build your own electron app from the repository. The build you tried to do earlier needs to be done on your PC, not on the server.

Ok, Thanks Freddie, I got it. and the remote control works now.

I appreciate your support very much. :100:

Regards,
Taha

This post was flagged by the community and is temporarily hidden.