Error creating contexts for s2sin: LuaSec (required for encryption) was not found


#1

Hi team,
Pls help me solve issue with prosody.

error Error creating context for c2s: LuaSec (required for encryption) was not found
error Error creating contexts for s2sout: LuaSec (required for encryption) was not found
error Error creating contexts for s2sin: LuaSec (required for encryption) was not found

Thanks


Alone in the room
#2

OS version, prosody version?


#3

OS: Ubuntu 16.04 x64
Prosody: 0.10.2


#4

Which repo are you using for prosody is their official repo? Have you added some new repo?


#5

Yes. first time i quick install jitsi success. I want to storage prosody to msql, so i update new prosody repo but next jitsi meet something issue. After that I remove jitsi and reinstall include prosody. And now it is boom, work with issue.


#6

i am using mysql as my storage with prosody 9.10 more than 2.5 years with no issues. in my opinion, u shouldn’t use prosody 10.X since jitsi-meet stable still uses 9.X
it is not worth waste the time. :sunglasses:


#7

Hi @Tanvir,
I’m trying to downgrade prosody.
Do you have guilde to downgrade prosody from 0.10 to 0.9? pls share link to me?
and first i try to connect prosody to MySQL but it announce “miss DBI bla bla” then i update repo, so it fail.
Could you tell me how to storage prosody to MySQL or share me a guilde working with jitsi.

Thanks for support,


#8

Why it’s not working? What errors are you getting? They are deb packages, you downgrade them as you do with other deb packages – either directly by installing the older version or going to aptitude and selecting the package for downgrade. Of course, first backup the configs, just in case.


#9

first download the package from prosody repo using wget,
wget https://ubuntu.pkgs.org/16.04/ubuntu-universe-amd64/prosody_0.9.10-1_amd64.deb.html
then run dpkg command,
dpkg -i prosody_0.9.10-1_amd64.deb
after that edit prosody.cfg.lua file and find the following lines and add ur dbname, dbuser, password etc,

--storage = "sql" -- Default is "internal"

-- For the "sql" backend, you can uncomment *one* of the below to configure:
--sql = { driver = "SQLite3", database = "prosody.sqlite" } -- Default. 'database' is the filename.
--sql = { driver = "MySQL", database = "prosody", username = "prosody", password = "secret", host = "localhost" }
--sql = { driver = "PostgreSQL", database = "prosody", username = "prosody", password = "secret", host = "localhost" }

u can use whatever db either one, for my case i use mysql, here is a ref for you

from my experience, jitsi-meet database works with secure-domain only so u need to configure VirtualHost authentication is “internal_plain”

after this, u need to install lua-dbi-mysql package so that it can talk to prosody. once done u can restart prosody followed by registering user like this,

systemctl restart prosody
prosodyctl register focus auth.yourdomain.com focussecret
prosodyctl register username yourdomain.com userpass

the focus password must be the same one that u used in jicofo config otherwise jicofo wont be able to authenticate. let me know how it goes


#10

Hi @Tanvir,
issue is still " Package lua5.1-sec is not installed."
This is error when i run.
I think we are need lua5.1-sec, and the worst i will reinstall all.
But i think it is not a good solution.

root@vultr:/var/log/jitsi# dpkg -i prosody_0.9.10-1_amd64.deb
dpkg: warning: downgrading prosody from 0.10.2-1~xenial1 to 0.9.10-1
(Reading database … 114657 files and directories currently installed.)
Preparing to unpack prosody_0.9.10-1_amd64.deb …
Unpacking prosody (0.9.10-1) over (0.10.2-1~xenial1) …
dpkg: warning: unable to delete old directory ‘/var/lib/prosody’: Directory not empty
dpkg: dependency problems prevent configuration of prosody:
prosody depends on lua5.1-sec; however:
Package lua5.1-sec is not installed.

dpkg: error processing package prosody (–install):
dependency problems - leaving unconfigured
Processing triggers for systemd (229-4ubuntu21.2) …
Processing triggers for ureadahead (0.100.0-19) …
Processing triggers for man-db (2.7.5-1) …
Errors were encountered while processing:
prosody
root@vultr:/var/log/jitsi#


#11

Thanks all for support.
I solved issue.
I dont know what is LuaSec and i dont know why luaSec can not install with prosody 0.10?