Error connecting to conference by phone

I am trying to get everything ready for a trial conference on Monday. One of the participants will have to join by phone.
I have started a new conference on my PC and then tried to dial in - I am using the UK phone number from the list of list of “more numbers” on the “i” button.
The voice asks me to key in the conference ID - I key in the pin number and press the #
The voice tells me “she” is connecting me to my conference.
I then get one of two responses:

  1. The line drops or
  2. The voice says there is an error connecting me to my conference and asks me to re-enter the conference ID.
    Grateful for any thoughts.
    Duncan

Are you using meet.jit.si or your own installation?

Try a different meeting name and see it if works.

Thank you reset.
I am using meet.jit.si
I have just re-tried. It seems to work fine if I don’t have a password but the error occurs if I have set a password. Is that normal?

That’s expected behavior.

Thanks again reset

We were able to connect by telephone on Thursday April 2nd, but it took a couple or three tries entering the ID.

Thanks RonP - was that with a password enabled?
It works perfectly without a password - but not with. (For me!)