Error building jitsi-meet from source code (Ubuntu 18.04, node 14.17.0 and npm 6.14.13)

I’m trying to build from source code and I get the following error:

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! jitsi-meet-load-test@0.0.0 build: webpack -p
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the jitsi-meet-load-test@0.0.0 build script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/motmiprodadmin/.npm/_logs/2021-06-14T15_45_14_717Z-debug.log
Makefile:25: recipe for target ‘compile-load-test’ failed
make: *** [compile-load-test] Error 1

I’m building with a regular user, on Ubuntu 18.04 with node V14.17.0 and npm 6.14.13

I tried deleting the nodes_modules dir and got the same result.

Any suggestions?

Thanks!

What message do you get just before this block of errors? What platform are you building on? OS version?

@plantiword welcome to the community!

Did you modify the line with jitsi-meet-load-test in package.json, by any chance? Have you seen this topic: [How to] How to build Jitsi Meet from source: A developer's guide

Hi Freddie, the OS is Ubuntu 18.04, node 14.17.0 and npm 6.14.13 as stated on the subject.

Hi @corby , I followed your instructions and it worked. Thanks a lot!