Error about web server


#1

i am newbie at jitsi i have created a blank html page at my company for jitsi chat page but it show error while generating certificate it show the following error
Errors were encountered while processing
jitsi-meet-web-config
jitsi-meet-prosody
jitsi-meet

Do i have to do some coding on html page

http://tech-bridge.biz/vc/VC/conf.html
this is where i was trying to put jitsi in

please help


#2

This is the guide for deploying it: https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md
Do you encounter problems when you try to apt-get install it? What is the operating system version you are using?
You don’t need to create any page, and by the way it will not work under http, webrtc works only under https.


#3

sir i have followed the same guide i am using ubuntu 16.04
when this guide doesnot work i shift to this link


but still encountering same error
using apache2 engine


#4

Give details for the error? What it is? What is the command you are executing? Without giving details you will not be able to get any help.


#5

sorry for late reply
I have changed my domain from http to https but it show the same error
the error comes after I use the command

sudo apt-get install -y jitsi-meet

after entering the domain name it show the error :
Error were encountered while processing
jitsi-meet-web config
jitsi-meet-prosody
jitsi-meet
E:Sub-process /usr/bin/dpkg returned an error code(1)


#6

Is there something else in the error? Can you show the whole output?


#7

Sir
this the full error


#8

There must be something with the apache2 configuration/scripts.

I’m curious why didn’t you follow the official tutorial https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md?

I will check the apache install and configure these days.

If you don’t need apache2, I would recommend using the default jetty or nginx and try re-installing everything. If you want nginx, install it after removing apache2.

apt-get remove apache2
apt-get --purge remove jitsi-meet jitsi-meet-web jitsi-meet-prosody jitsi-meet-web-config jicofo jitsi-videobridge
echo 'deb https://download.jitsi.org stable/' >> /etc/apt/sources.list.d/jitsi-stable.list
wget -qO -  https://download.jitsi.org/jitsi-key.gpg.key | apt-key add -
apt-get update
apt-get install jitsi-meet

Does this work for you?


#9

sir
without using apache2
I am still receiving the same error
I was following your instruction


I think I am using web server wrong
I have made an additional page to my company official website for a web server
https://tech-bridge.biz/vc/VC/conf.html

is this a wrong way


#10

What do you mean? I don’t understand?

When you install jitsi-meet it configures itself with a virtual host in the webserver, with a name that you enter when installing.


#11

I just created a VM with ubuntu 16.04 on DO and following the instructions with apache2 (the link you posted above) and there was no error during installation. Maybe between steps you do something to your webserver that conflicts with the configurations that jitsi-meet does when installing.


#12

Hi, we have a website hosted from a hosting services provider. the jitsi-meet which I am installing is on a private server in my lab. Once jitsi meet asks us to give domain name, I give as: tech-bridge.biz (which is hosted on a public cloud, provided by the hosting services provider). We have overcome the error of path, ie jitsi-meet does not display error anymore for the file path, file is created on the private hosting server where I am installing my jitsi-meet. created file path is: /etc/prosody/conf.avail it has created a file (tech-bridge.biz.cfg.lua)
But now it is unable to configure the file. I suspect it is something to do with the file created by jitsi. can you suggest for possible workaround/solution?
thanks for the help in advance


#13

Hi Damencho, need your help here. I am getting the error that the jitsi meet is not able to configure the file. Need your help here.


#14

What is the os version? Give the steps you execute to see the problem?


#15

@ damencho
the os version is Ubuntu 16.04 server
the commands used are
apt-get remove apache2 apt-get --purge remove jitsi-meet jitsi-meet-web jitsi-meet-prosody jitsi-meet-web-config jicofo jitsi-videobridge echo ‘deb https://download.jitsi.org stable/’ >> /etc/apt/sources.list.d/jitsi-stable.list wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | apt-key add - apt-get update apt-get install jitsi-meet

I put the domain as tech-bridge.biz
after this step the following error shows up


#16

I was doing a fresh install of ubuntu 16.04 and I do not see any error, when using apache2 + jitsi-meet, it must be something on your system.
Can you try restarting apache2 does it succeed without an error?


#17

@damencho
I thought that too
I thought because of system error there must be error so I shift to aws
there is the same error coming while performing the same procedure in aws


#18

Give the exact steps you use from booting the machine and the aws image you are using. Did you try the restarting of apache, was that the problem? Have you checked apache logs after restarting?