Err_too_many_redirects

Hi i have installed the jitsi with cloudflare dns and universal ssl and server in nginx with ubuntu. i have no idea how to disable this redirection from http to https in jitsi. Can anyone help me with this issue. Sorry if im asking silly questions as im still a beginner who is trying my best to improvise my knowledge more. Thank you

1 Like

@damencho
i have tried this and succesfully i can see the page loading properly but i can see nginx homepage only. Have i done something wrong here

If the ssl termination is done somewhere else and you access the deployment using http. Make sure the communication between those two places is private and protected and most probably you need to move the settings from the https part to the http part

What is that file and where is it located? Can you supply a file path to that example so i can find it on the system?

Found that file is located at: /etc/nginx/sites-available/[DOMAIN] and editing it just makes the nginx welcome page appear. Im still looking for solutions for the “ERR_TOO_MANY_REDIRECTS” just like OP.

After tryouts I found that this is only related to Cloudflare. Because I had no redirect problem before moving to Cloudflare.

In my case it was a simple fix like this. Select SSL/TLS > Overview and select Full (strict) as in the image.

Really, you can try this out first before any other actions.