End meeting for all

I would like to end the meeting for everyone, but I got the error message: Cannot end conference: is not supported. What’s wrong? (I just changed _endConferenceSupported to true inside Toolbx component)

That feature requires a Prosody module, you can’t just enable it in the UI. Look in the prosody config and enable the module, then the option should become available.

As I understood I should add end_conference to the jaas.cfg.lua, am I right?

No, to the main config file where you have your main virtual host.

sorry, unfortunately I don’t understand where it is because I’m just using a cloned jitsi-meet repo without any configuration.

This docs explain: jitsi-meet/mod_end_conference.lua at master · jitsi/jitsi-meet · GitHub

Our of curiosity, why are you not installing it via packages / docker?

I don’t have experience usage docker. Should I create a prosody.config file and add the config to it?

How about a simple debian setup? Then you’ll have the default config as a head start: Self-Hosting Guide - Debian/Ubuntu server | Jitsi Meet

but why can’t I just change something in the jitsi-meet repository files? will it work on macOS?

Jitsi Meet consists of several components, the jitsi-meet repository is just the frontend, this requires a backend module, as I mentioned.

I have a question , what do you mean about installing via packages (npm)?

is it about Self-Hosting Guide - Debian/Ubuntu server | Jitsi Meet?


ok, I will try, thanks, maybe do you have any simple examples (config files or something else) ?

The apt command should bring you a working deployment, configured … you don’t need anything other than DNS and port-forwarding to the machine hosting it.

Hello, I use docker and env file, add end_conferens to XMPP_MUC_MODULES but nothing works, what am I doing wrong?

In Docker that feature is enabled by default, there is nothing you need to configure.

I’m using stable version 7648-4 and it doesn’t work, any ideas?

That functionality is only available on versions >=[stable-7830. Please update.

1 Like


I update to 2.0.7882-1 and function doesn´t work :frowning: