Enabling websockets in Docker

Greetings,

I have a docker-jitsi-meet deployment humming along behind a Traefik reverse proxy on Ubuntu 20.04 VPS, and I’d like to enable websockets. According to this post, the docker distro hasn’t been updated yet to support websockets.

Has anyone gotten websockets to work with their Docker deployment - and in particular, with Traefik?

I’m starting work on support for the new config in Docker, so hopefully will have something there soon.

4 Likes

Awesome sauce! :smiley:

That would be fantastic!!! Thanks bbaldino for the awesome work!!!

@bbaldino Is below PR related to websockets?

if this is going to be the structure then where to put Octo config. Currently It is in sip-communicator file(need to add by user and then build their own docker jvb image).

Like this

# Octo config
{{ $ENABLE_OCTO := .Env.ENABLE_OCTO | default "0" | toBool }}
{{ if $ENABLE_OCTO }}
org.jitsi.videobridge.octo.BIND_ADDRESS={{ .Env.HOST_IP }} # need to set it 0.0.0.0 
org.jitsi.videobridge.octo.PUBLIC_ADDRESS={{ .Env.HOST_PUBLIC_IP }}
org.jitsi.videobridge.octo.BIND_PORT={{ .Env.OCTO_BIND_PORT }}
org.jitsi.videobridge.REGION={{ .Env.REGION }}
{{ end }}

It would be great if you can add this to sip or config file. It will ensure that there is no need to create jvb docker image to use octo.

1 Like

Yeah we can add this unless @saghul has any thoughts on doing it differently. I’d probably do it in a separate PR.

1 Like

there’s an issue(more of a question) already and waiting for @saghul comment

https://github.com/jitsi/docker-jitsi-meet/issues/643

I just updated my docker-jitsi-meet deployment to stable-5142. Are websockets enabled by default? If not, how does one go about enabling websockets?

When I view the Chrome console, I see no websockets in the Network --> WS tab.

Thanks in advance for any help.

EDIT: I’ve made some headway. I’m now at least getting an error related to websockets, but I don’t quite know how to resolve it…

Can anyone shed some light? It’s not clear what docker-specific changes to make.

@Shotster good question mate. I also upgraded to stable-5142 and then jitsi-meet started failing with the same reason. I also think this is reason to believe that Websockets is enabled by default from now on? Have you made any progress in setting this up with Docker?

Hi @Arthur_Morales,

Indeed WebSockets is now enabled by default, and they are working fine for me now. This issue was a misconfiguration on my end. However, there’s another issue related to the lobby. I think it’s been identified, but it’s not yet in the docker stable release.

@Shotster hey man, thanks for pointing out the issue on Github. I couldn’t understand very well why is it that LOBBY feature doesn’t work with JWT and GUEST mode enabled. Does that mean I can’t use ENABLE_GUESTS and ENABLE_LOBBY at the same time in docker? I still couldn’t manage to figure out a way to get enable_lobby feature working with docker. have you succeeded on that?

Also, the “misconfiguration” you mean in your link is the DOCKER_HOST_ADDRESS environment variable right? I defined that and my websockets are still pointing to wss://localhost:8433/xmpp-websocket so I disabled it altogether so I can keep using jitsi.

Correct, but only IF you’re also using JWT authentication - at least not in the current stable release. You’d have to build your own images using the latest repo commits if you’re comfortable doing that. Otherwise, you’ll have to wait for the official docker release to be updated.

I think that setting is relevant only if you’re trying to use Jitsi on a LAN. If you’re configuring a “regular” deployment on a public server, you don’t have to worry about it.