Enabling websocket

Hello community! Does anybody know how to fix this error when trying to join a room?

Is that the correct domain? Is a trusted certificate used for that domain?

It is a self-signed certificate, the domain is correct yes.
If I go to the mentioned domain with http instead of wss, it says:
“It works! Now point your WebSocket client to this URL to connect to Prosody.”

I think the certificate is not at fault here, beacuse I ran chrome with flag to ignore certificates and the same error popped up.

The error that is printed shows the problem is the certificate, search what that error exactly means.

So the problem lies not in the config files (websocket configurations) within Jitsi if this message appears and the domain name is correct in the error?

Yep, seems the websocket connection does not trust the certificate. Why don’t you try with let’s encrypt certificates?

1 Like

It’s hosted on a private domain, so I can’t use let’s encrypt.
Also I had the wrong docker host address, now that I put the correct address, the same error persists but instead of ERR_CERT_AUTHORITY_INVALID, the error code is 403 (forbidden).
Is there a way to have jitsti trust all certificates for testing purposes?

Its the browser, not jitsi … I don’t know… 403 maybe different … Check nginx logs

1 Like