Enabling Transcription UI on Jitsi-meet own installation


#1

I am having difficulties to enable the transcription UI that was recently implemented on jitsi-meet.

On the make dev environment, everything works properly, Jigasi is called as a hidden object and the transcription works properly.

For my regular deploy environment, on the other hand, I am just able to call the transcription module using console calls. When I press the CC button it just changes the local state without doing anything else. It doesnt seems to be attempting to call JIgasi at all.

I have attached my config file for jitsi.

Regards

config.txt (13.8 KB)


Beta.meet.jit.si Configuration files
#2

Do you see any js console errors or messages when you click the cc button? Can you upload your js console after you click the button?


#3

On the problematic version and it is returning nothing. I output the state variable ‘requestingTranscription’ and it is actually switching state properly on button press.

I think that somehow conference.room.dial(TRANSCRIBER_DIAL_COMMAND) call is being blocked somewhere.

If you need, I can provide other configs.

Thank you


#4

Which versions you use for meet/jicofo and jigasi, are you using latest everywhere?
When it doesn’t work you don’t see anything in the js console as a reply from jicofo?


#5

I am using the latest version from master of the three of them.

It doesnt output anything, not even an error message. If I force a call from console using conference.room.dial() it calls Jigasi properly as it used to.


#6

I am still stucked on this issue, there are some locations that had meet.jit.si domain hardcoded and I am changing it to test.

Just to know, how does make dev works? Where is it getting the other services from (Jicofo,jigasi, etc)? I want to compare how the other services are configured on dev with mine.

Regards


#7

Still not working. One of the differences that I noticed is that when I invoke conference.room.dial(“jitsi_meet_transcribe”), the transcriber join as a regular user on my installation instead of as a hidden user when I call on make dev/beta.meet.jit.si. I still cant figure out the difference between the settings…

Below is the output for the js console when I start a session.

@damencho Any idea? Sorry for bothering a lot about this.

Screenshot%20from%202018-10-26%2014-15-10


#8

Would you be able to share your jigasi sip-communicator file, and check if there’s a difference between your dev and production file?


#9

Here is the sip-communicator file. I dont have an SIP account set up for it but I read elsewhere that it was not necessary for the transcription only.

sip-communicator.txt (7.9 KB)


#10
# If you want jigasi to perform authenticated login instead of anonymous login
# to the XMPP server, you can set the following properties.
# org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
# org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
# org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

needs to be defined. It should look like

org.jitsi.jigasi.xmpp.acc.USER_ID=recorder@recorder.<your_domain>
org.jitsi.jigasi.xmpp.acc.PASS=<your_password_for_recorder_domain_check_prosody>
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false
org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
# org.jitsi.jigasi.xmpp.acc.ALLOW_NON_SECURE=true (if facing ssl errors)

Sorry for the bad documentation on this. Your dev environment most likely works because it points to beta.meet.jit.si by default, which has the right settings.


#11

I am verifying prosody .cfg.lua file and there is no recorder component. So I need to add it as:

Component “recorder.<my_domain>”
component_secret = “mysecret”

And then add this configuration to jigasi?

Just in case, is the configuration files for beta.meet.jit.si available somewhere to check?
@Nik_V


#12

I’m not entirely sure, I’m not very familiar with prosody. You can call the component anything, it doesn’t have to be recorder.

You can only check the config.js and interface_config.js, which will be delivered to you when you visit the website.


#13

Just note that the config.js file needs to include for example:

hiddenDomain: "recorder.beta.meet.jit.si"

#14

Thank you, I will try these changes. I will come back if it (hopefully) works.

Btw, is the setup for this the same as for Jibri? I am running jibri on my server so I didnt configure for it.

Regards


#15

I made the changes as recommended plus the setup for jibri. I got the following error, any clue?
@Nik_V

error.txt (7.9 KB)


#16

Have you tried the above?
Also see: Cannot make or receive a SIP call via Jigasi in "secure domain" setup; looks like a certificate issue?


#17

@Nik_V Thank you so much. Following your suggestions, I managed to make jigasi join as a hidden user with the TR icon being displayed instead of a new user. I assume that it is joining as an authenticated user on.

I added ALLOW_NON_SECURE (ALWAYS_TRUST_MODE_ENABLED was enabled already by default).

However, the CC button is still not calling the transcriber and I am trying to find the reason, it still behaves like before with no response nor error message on the js console or on the logs. I changed the jigasi user so it matches the behavior on beta environment. (jigasi@recorder.domain.com)

BTW, I had to comment the following setting:
org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}

Because it was giving the error message that I posted before:

org.jivesoftware.smack.SmackException: No supported and enabled SASL Mechanism provided by server. Server announced mechanisms: . Registered SASL mechanisms with Smack: [SASL Mech: GSSAPI, Prio: 100, SASL Mech: SCRAM-SHA-1-PLUS, Prio: 100, SASL Mech: SCRAM-SHA-1, Prio: 110, SASL Mech: DIGEST-MD5, Prio: 200, SASL Mech: CRAM-MD5, Prio: 300, SASL Mech: PLAIN, Prio: 400, SASL Mech: X-OAUTH2, Prio: 410, SASL Mech: EXTERNAL, Prio: 500, SASL Mech: ANONYMOUS, Prio: 500]. Enabled SASL mechanisms for this connection: [ANONYMOUS]. Blacklisted SASL mechanisms: [SCRAM-SHA-1-PLUS].


#18

Can you share your Jicofo logs (should be something like /var/log/jicofo.log).
Can you check that the presence is sent accordingly, after you clicked the cc button? See my attached image for how it should look. It’s important that the jitsi_participant_requestingTranscription property is set to true.

@damencho might know more about the bosh error you’re encountering.


#19

The parameters at jitsi-meet seems to be set properly, this is the output when I click on the CC button. It doesnt return anything.

Also, if I call the transcriber from console the output comes with a random username instead of “Transcriber” as it used to be
Screenshot%20from%202018-10-31%2003-29-21

The logs for jicofo, it is not getting anything.
jicofo.txt (348 Bytes)

Regards


#20

You should see these messages:

Jicofo 2018-10-31 08:08:59.639 FINE: [25] org.jitsi.jicofo.jigasi.TranscriberManager.log() initialised transcriber manager

Jicofo 2018-10-31 08:09:48.014 INFO: [77] org.jitsi.jicofo.jigasi.TranscriberManager.log() Attempting to invite transcriber

Jicofo 2018-10-31 08:09:53.328 INFO: [77] org.jitsi.jicofo.jigasi.TranscriberManager.log() transcriber was successfully invited

It would be very strange if you do not see at least the first one, which should happen whenever a new room is created.