Enabling HTTP authentication using docker-jitsi-meet

I have docker-jitsi-meet up and running successfully, but due to this apparent bug I had to disable authentication, which means whenever those containers are running, my jitsi server is wide open to the world.

Is there a way to enable basic HTTP authentication in the nginx web server that’s bundled in docker-jitsi-meet, so that visitors would have to authenticate before even getting the jitsi front page and joining/creating a room? Or is there any other recommended way to easily add some kind of security layer in front of a jitsi server?

So I went ahead and enabled basic HTTP auth by editing config/web/nginx/site-confs/default:
satisfy any;
allow 192.168.0.0/16;
allow 127.0.0.1;
deny all;
auth_basic “Protected Area”;
auth_basic_user_file .htpasswd;
and creating the .htpasswd file, and it works great for web browser clients! But, the jitsi mobile app does not appear to support HTTP auth on the meeting server; even if I put the credentials in the server url, as in https://user:pass@my.domain, it still won’t connect. So that’s a pity.

1 Like

Not running Docker, but just ran into the same issue. Web “clients” works fine with basic HTTP authentication (running Nginx), but Jitsi mobile app refuses to join any meetings after enabling this. Which, as @atfrase points out, is a shame.

FYI, since http auth works on the web client, I filed a github issue for the mobile apps to add support for it to remain consistent.