Enabling google analytics

meet
#1

So I want to add my google analytics tracking id to my project. First I want to test if it works so I decided to add it to a local dev deployment. I did the following changes to my config.json:

// A list of scripts to load as lib-jitsi-meet "analytics handlers".
analyticsScriptUrls: [
     "libs/analytics-ga.js" // google-analytics
],

// The Google Analytics Tracking ID
googleAnalyticsTrackingId = 'my tracking key',
disableThirdPartyRequests: false,

I checked to see if any events were being reported by nothing was there. The network tab in the developer tools did not show anything. The analytics-ga.js file is under libs folder locally but when I look at in the sources folder of developer tools in chrome I don’t see analytics-ga.js file. I see the rest of the files:

app.bundle.min.js
do_external_connect.min.js
external_connect.js
lib-jitsi-meet.min.js

I compared it with the libs folder of https://meet.jit.si and in there I do see analytics-ga.js.

Am I missing anything in my setup?

0 Likes

#2

Ok just deployed to our cloud and analytics-ga magically appears. Definitely has to do something with the webpack setup to disable it for local/dev but im not gonna worry about it :slight_smile:

So just by overriding these params in the config.json you’re good to go.

0 Likes