Enabling Calendar Integration?

Hello I was curious as to how to enable the calendar for the welcome page. I saw there was a config value that I turned on, but that didn’t seem to do anything. What am I missing here? Any help would be awesome.

Check the interface_config.js there is a flag recent_list_enable u need to set it to true

I did set that and it still isn’t working. Not sure what to do from here. I went into the /etc/prosody/meet-config.js and flipped the enable calendarintegration to true but that didn’ t seem to do the trick either.

Have you added your google app id in config.js?
You need to create google app id for which calendar api is enabled.

I did and I get a gray screen. I am just supposed to add this to the config file or is there a certain spot for it? I didn’t see an obvious spot for it.

You can always check meet.jit.si config as a reference

googleApiApplicationClientID: "......apps.googleusercontent.com",
 

Hi Sir @damencho,

Not familiar regarding googleApi client id and to microsoft.

Its ok to use the same ID like you mentioned to our own server? to enable the calendar?
or we need to use our own?

googleApiApplicationClientID: “39065779381-bbhnkrgibtf4p0j9ne5vsq7bm49t1tlf.apps.googleusercontent.com”,
microsoftApiApplicationClientID: “00000000-0000-0000-0000-000040240063”,
enableCalendarIntegration: true,

thank you

The ids on meet.jit.si can work only for that domain.

1 Like