Enable VP9 on docker

Hi, the new docker’s image of jitsi meet docker-jitsi-meet-stable-6433supports now VP9 configuration.

There is any guide show how to enable VP9 in docker?

there is any help?

I don’t use Docker so can’t provide much help, but did you check the git log for the (abbreviated) hash provided in the changelog ?
09cf0a8 web: add env variables for configuring vp9

git log | grep 09cf0a8
* 09cf0a8 web: add env variables for configuring vp9
commit 09cf0a89519b82c8c03d3e96e1e15bebea28445d

git show 09cf0a89519b82c8c03d3e96e1e15bebea28445d

--- a/docker-compose.yml
+++ b/docker-compose.yml
@@ -83,6 +83,7 @@ services:
(...)
+            - P2P_PREFERRED_CODEC
(...)
@@ -100,13 +101,24 @@ services:
(...)
+            - TOKEN_AUTH_URL
+            - VIDEOQUALITY_PREFERRED_CODEC
+            - VIDEOQUALITY_ENFORCE_PREFERRED_CODEC
+            - VIDEOQUALITY_BITRATE_H264_LOW
+            - VIDEOQUALITY_BITRATE_H264_STANDARD
+            - VIDEOQUALITY_BITRATE_H264_HIGH
+            - VIDEOQUALITY_BITRATE_VP8_LOW
+            - VIDEOQUALITY_BITRATE_VP8_STANDARD
+            - VIDEOQUALITY_BITRATE_VP8_HIGH
+            - VIDEOQUALITY_BITRATE_VP9_LOW
+            - VIDEOQUALITY_BITRATE_VP9_STANDARD
+            - VIDEOQUALITY_BITRATE_VP9_HIGH

Note that I have not the foggiest idea why a TOKEN_AUTH_URL is included in these changes…

I have changed this on .env to test VP9 on docker and I able to see VP9:

    #enable VP9
      ENABLE_CODEC_VP9=true
      ENABLE_CODEC_VP8=false
     ENABLE_CODEC_H264=false

but I don’t now what value to put for other variables?:

         VIDEOQUALITY_BITRATE_H264_LOW
         VIDEOQUALITY_BITRATE_H264_STANDARD
        VIDEOQUALITY_BITRATE_H264_HIGH
         VIDEOQUALITY_BITRATE_VP8_LOW
        VIDEOQUALITY_BITRATE_VP8_STANDARD
         VIDEOQUALITY_BITRATE_VP8_HIGH
        VIDEOQUALITY_BITRATE_VP9_LOW
        VIDEOQUALITY_BITRATE_VP9_STANDARD
        VIDEOQUALITY_BITRATE_VP9_HIGH
        VIDEOQUALITY_ENFORCE_PREFERRED_CODEC
        VIDEOQUALITY_PREFERRED_CODEC

my goal is to use VP9 as preference then as the VP8 as second preference

as a wild guess, I’d say that removing your Jicofo hack and setting VIDEOQUALITY_PREFERRED_CODEC to VP9 could be the way.

I tested, but always prefers VP8, till ENABLE_CODEC_VP8=false to have VP9

maybe set VIDEOQUALITY_ENFORCE_PREFERRED_CODEC to true ?

yes that one, it works. I’m wondering what is the best value to give to these variables:

     VIDEOQUALITY_BITRATE_VP8_LOW
    VIDEOQUALITY_BITRATE_VP8_STANDARD
     VIDEOQUALITY_BITRATE_VP8_HIGH
    VIDEOQUALITY_BITRATE_VP9_LOW
    VIDEOQUALITY_BITRATE_VP9_STANDARD
    VIDEOQUALITY_BITRATE_VP9_HIGH

any suggestion?

I disabled codec H264.

here what I set on .env:

#enable VP9
ENABLE_CODEC_VP9=true
ENABLE_CODEC_VP8=true
ENABLE_CODEC_H264=false
VIDEOQUALITY_PREFERRED_CODEC=VP9
VIDEOQUALITY_ENFORCE_PREFERRED_CODEC=true

well, maybe these parameters are corresponding to the videoQuality section in config.js:

    //    maxBitratesVideo: {
    //          H264: {
    //              low: 200000,
    //              standard: 500000,
    //              high: 1500000
    //          },
    //          VP8 : {
    //              low: 200000,
    //              standard: 500000,
    //              high: 1500000
    //          },
    //          VP9: {
    //              low: 100000,
    //              standard: 300000,
    //              high: 1200000
    //          }
    //    },

setting this to true will break VP9 <–> VP8 fallback in the case of Apple devices. VP9 isn’t working on Apple devices. Not a Jitsi bug.

don’t touch these settings. By default they all set to true only.

setting this to VP9 is sufficient. you need min. 3 users to test it OR disable P2P

Set P2P_PREFERRED_CODEC=VP9 for enabling VP9 in P2P mode.

1 Like

yes.

it’s work, it shows VP9 in P2P also:

#enable VP9
ENABLE_CODEC_VP9=true
ENABLE_CODEC_VP8=true
ENABLE_CODEC_H264=false
VIDEOQUALITY_PREFERRED_CODEC=VP9
P2P_PREFERRED_CODEC=VP9
#VIDEOQUALITY_ENFORCE_PREFERRED_CODEC=false

Thanks all of you!