Enable password for rooms

Hi there,
I just installed jitsi-meet on my own server. Everything works fine except that there is no “add password” button. What do I have to do to enable that option?

Kind regards
Michel

1 Like

This is available only to the moderator of the room, by default this is the first participant to join, its thumbnail is marked with a star.

1 Like

Hi Damian,
thank you for your quick reply!

I am the creator (=moderator?) and single person of the room. On my own server I have no Add password next to the Copy link after clicking on the i-button. On https://meet.jit.si all works fine.

To create a room I changed the settings to ask for a password as described on https://github.com/jitsi/jicofo#secure-domain (I skipped the “configure ‘anonymousdomain’” part though).

To check wether the secure domain part was faulty I changed the following config option to:

authentication = “anonymous”

in

/etc/prosody/conf.avail/[your-hostname].cfg.lua

and deleted

org.jitsi.jicofo.auth.URL=XMPP:jitsi-meet.example.com

in

/etc/jitsi/jicofo/sip-communicator.properties

Then I restarted via

prosodyctl restart

After that, the first time I created a new room I could create a room password. But after leaving and creating a new one the option was gone. Even restarting prosody didn’t help.

Do you have any idea what’s wrong?

Kind regards
Michael

1 Like

Hi, I completely de-/reinstalled jitsi. I have the out-of-the-box config. There is still no option for setting a room password .“Add password” next to “Copy” is just not there :frowning:

What am I missing?

All help is highly appreciated :slight_smile:

I now even tested with a complete new server - no success :frowning:

You are checking for it in the moderator participant UI, right?

I am the only one in the room. If I am on my own server there is no “Add password” button. If I lock in the same way on meet.jit.si there is an “Add password” button.
Is there a special moderator section that I do not see??

I just tested it. I did a new deployment without modifications on a new VM. Open a conference, set a password and enter with second participant and I’ve been asked for password.
Then I changed anonymous to authentication = "internal_plain", created a user that I can use, then I opened a new conference I had ‘Add password’, set a password, open a second tab where I was asked about username and password and after authenticating I was asked about the room passcode.

There must be some modification on your side that breaks it, are you using default client with no modifications? Did you add something to your configs? What user are you using to authenticate, is that a one you created with the register command?

I had the same issue, and I remembered I setup the app_id and app_secret during the install process.
So I added them into the Moodle jitsi system admin settings, and it solved this issue.

app_id and app_secret are inside your /etc/prosody/conf.avail/[your-domain] file.

Thanks for your comment! I just tried it again after six month but with the same result: no password options available. I did the installation from scratch on a clean Ubuntu 18.04 LTS 64bit (on a virtual server) according to New tutorial: Installing Jitsi Meet on your own Linux Server. I am using jetty as web server.

I did not perform any extra steps so I also did not setup an app_id nor an app_secret as far as I know.

If I check the folder
etc/prosody/conf.avail/[my-domain]
there is only one file named
[my-domain].net.cfg.lua.

I think this is not an app_id nor an app_secret?

What about using:

authentication = “anonymous”

I was partly successful by changing to

authentication = “anonymous”

in the section

VirtualHost “auth.[my-domain]”

But after leaving the room and entering a new one the password option was gone :unamused:
One or two times after restarting via

prosodyctl restart

it was there again. But I couldn’t join from another computer and also loosing this password option my installation seems very buggy…

I could not see the “Add a password” in brave browser, but it did appear in chrome.

Hi everbody !! What a great application !
So I have same issue. I don’t have “Set password” enable with Firefox after make authentication active. So for more security I need to be able to create a password. How can I do this ?
(sorry for my poor english…)

Strange thing is that I see the “Set password” on meet.jit.si but not on my own server instance…

@bmoogin you can set a password “externally”

https://www.reddit.com/r/linux/comments/ayy0sj/jitsimeet_authentication_for_dummies/

-Locate the virtual host with your hostname(should be at the top of the file) and change authentication options to “internal_plain”. It should look like this afterwards.

VirtualHost “YOUR-SERVER-HOSTNAME”
authentication = “internal_plain”

-Create user using prosodyctl. This is where we create users that will sign into Jitsi-meet.
sudo prosodyctl register USERNAME YOUR-SERVER-HOSTNAME PASSWORD

Is this confusing two separate things?

1.) restricting the ability to create a room: add a user and password to prosody, and configure jitsi via the “secure domain” instructions. If you don’t do this, anyone with access to the server (probably the whole world) can use your server for video conferencing.

2.) restricting the ability to join a room already created: moderator adds password via the browser when the room has been created. If you do not do this, once a room is created, anyone can join.

You are right, that’s definetely two different things. I wanted to point that out by saying:

you can set a password “externally”

:wink:

Hi, thanks for your response. But make authentication like this “it’s ok!”. The problem like Eric_Nelson and me we are talking about it’s the next. After complete and make working authentication the possibility to make a password to a room has disappear. And without this setting we can’t increase security access of a room.
Do you see the real problem ? And do you have a response about this ?

We can see 2 different things but when your point 1 is activate and enable, point 2 can’t be set… Is here the issue for me. If you have an answer…
Regards.