Enable mod_muc_size.lua module and configure nginx proxy

Hi!

firstly sorry if i do some stupid questions but is the first time that i am interact with Jitsi, Prosody and Lua.
I am interested to know how many participants are joined a random room name and saw that exists a module to resolve that request (mod_muc_size.lua) where have a GET in bottom of the file.

this module is already enable and ready to use or i have to enable by hand? If i have how can do that?

After that i configure a nginx proxy (nginx.conf)

location = /room-size {
** proxy_pass http://localhost:5280/room-size?$args&domain=domain.com;**
** proxy_set_header X-Forwarded-For $remote_addr;**
** proxy_set_header Host domain.com;**
** add_header Content-Type “application/json; charset=UTF-8”;**

Finally i am doing a rest request but not have a response json with a participant counter, however receive a 200 HTTP code with null content body.
These endpoint’s are protected with authorization (by default) ?

I am using a self deployment (with docker)

This is protected by jwt token that need to be passed … maybe there was a setting to disable that … Not enabled by default

Thanks @damencho

i can follow that example and edit prosody.cfg.lua in my docker?


Component “domain” “muc” is that line ?

Do you have any kind of suggestion to disabled jwt auth?

By default it is disabled: https://github.com/jitsi/jitsi-meet/blob/master/resources/prosody-plugins/mod_muc_size.lua#L25

I haven’t been successful yet and have some questions.
I have a Jitsi self deployment (docker) and running on mydomain.com

Configuration Steps:

  1. edit prosody.cfg.lua adding
    Screenshot 2020-11-15 at 23.17.50

  2. edit nginx conf file

i have to configure a specific [yourdomain].cfg.lua (prosody) and [yourdomain].conf (nginx) ?
at moment server response give a 502 Bad Gateway. It seems to me that the component muc size is not being loaded

No prosody error?

No error in prosody.
My question is if i am making the correct mod_muc_size activation on prosody.
Is only add a line Component “conference.jitsi.example.com” “muc” on prosody.cfg.lua config file ?

i check my domain/htpp-bind and it’s works.
Screenshot 2020-11-16 at 11.39.39

To enable this module add it in modules_enabled = { in the main prosody config: /etc/prosody/prosody.cfg.lua as:

modules_enabled = {
....
    "muc_size";
}

@bureska82… This may also help you:

thanks @damencho and @corby

I’ll try and give feedback later.