Enable lobby automatically before meeting is started

Using my self-deployed server (with authorization for owner/moderator and lobby mode enabled), I would like to create in advance the jitsi-meet link to participants without being online myself first, would this be possible with the “automatically enabled lobby mode” to restrict access?

Let´s assume other users get the link and already wait online (but cannot participate yet in the conference before I join the meeting as owner/moderator to start the conference), participants already waiting online to wait for lobby before they can kick into conference.

Currently (even with authorization), the other users kick in automatically into conference even though moderator is not into conference and before moderator will be able to enable lobby mode or set a password.

I have used JWT based authentication and with that it’s possible that 1st person who tried to join is not a moderator.
Currently I am restricting this default behavior of jitsi-meet to make 1st person as moderator using this in conference.js component -
const jwt = APP.store.getState()[‘features/base/jwt’];
let isModerator = jwt?.user?.moderator
role = isModerator?‘moderator’:‘none’

But I want if user is not moderator than he should not be able to join meeting and moved to lobby for wait.
Any help ?

Take a look at this plugin: prosody-plugins/lobby_autostart at main · jitsi-contrib/prosody-plugins · GitHub

Hi
I am trying to integrate this plugin but as a prerequisite, we need to have token_lobby_bypass plugin enabled. I am trying to integrate this plugin and test in my local docker based setup but not able to find 'Component “conference.meet.mydomain.com” “muc” ’ in /prosody/rootfs/defaults/conf.d/jitsi-meet.cfg.lua

not able to understand, where I am missing the dot. @shawn

I have tried adding this in Component “{{ $XMPP_INTERNAL_MUC_DOMAIN }}” “muc” && Component “{{ $XMPP_MUC_DOMAIN }}” “muc” also but it didn’t work

That would be this block here:

so if I’m reading that correctly, you should be able to enable that by adding the module to XMPP_MUC_MODULES env var.

I don’t use docker-jitsi-meet, but my guess would be you need to do the following:

  1. Download the following modules to prosody/prosody-plugins-custom your directory:
  2. Enable the modules by setting the following in your .env file
    XMPP_MODULES="lobby_autostart"  # comma-separate modules if you have more
    XMPP_MUC_MODULES="token_lobby_bypass"
    

And of course you need to have JWT auth working, and you would set the appropriate params in token for specific users to bypass the lobby.

Hi
thanks @shawn. it worked for me but I have to add these plugins in prosody/prosody-plugins-custom directly using docker terminal.
I wanted to add these plugins in this folder → jitsi-meet and I am using docker based setup where I am making a new docker image by replacing my custom jitsi-meet components for jitsi-web.
But I am not able to see these plugins when I am trying this 2nd approach.
How can we achieve this so that when we deploy, we don’t need to add these plugins manually.

Sorry, I’m not familiar enough with the docker setup to help with that.

I looks like the official plugins are copied to /prosody-plugins so perhaps you need to do the same with these modules when building your own image?

okay, got it.
Thanks