Enable Feedback popup / page

Hi Jitsi Team,

We have the parameter :slight_smile:
ENABLE_FEEDBACK_ANIMATION: true,

in our interface_config.js of out Jitsi Meet installation. But we don’t see the feedback popup opening when we hangup our meeting. We just go on the close page, or on the welcome page (if close page is not enabled).

What we have to do to enable the feeback popup with stars animations ?

Thanks for your support!

Regards

You need callstats enabled.

Thanks for your reply Damencho.
So I did it, just for test, by adding on config :

gatherStats: true,
callStatsID: ‘347489791’,
callStatsSecret: ‘169aw6v+hk9TbVuHN2SiDCgfkkU=’,
enableStatsID: true,
enableDisplayNameInStats: true,

But no popup windows for the review stars animation after that (I did a make of course to reload the application)

Maybe I missed something? Another parameter ? I took example on your jitsi-meet installation, and I don’t see other “place” to add the stats.

These are the conditions required to display feedback at the end of call: https://github.com/jitsi/jitsi-meet/blob/b7b2745daeddafe17d8b4654c43d969c7793ee61/react/features/feedback/actions.js#L52.

  • Not in filmstrip only mode
  • Not be a recorder (this is a wrinkle in the meeting recording implementation)
  • Not have submitted feedback already
  • Not already be showing feedback
  • Do have callstats enabled

Having callstats enabled eventually goes to this check (I think): https://github.com/jitsi/lib-jitsi-meet/blob/2108f80e3dc253f063ea450fd9fe68dfebd78e9f/modules/statistics/statistics.js#L159, which looks for callStatsID and callStatsSecret to be defined and disableThirdPartyRequests to be false (which likely it is by default).

If all the above conditions are met, I’d then check in the javascript console for the return value of APP.conference.isCallstatsEnabled() just to be sure if callstats is enabled. If you’re comfortable with the js console then adding a breakpoint here would also help you understand what might be incorrect: https://github.com/jitsi/jitsi-meet/blob/b7b2745daeddafe17d8b4654c43d969c7793ee61/conference.js#L2462. But first make sure all the above conditions are okay. You’re hanging up by clicking the hangup button, right?

Yes, that’s right :slight_smile:
Thanks for the great explanation ! I disabled the third parties option. I will enable it and see if it’s OK after that (all other conditions seems like OK).
Will give you feedback.

Oooooh yeah!
That was the trick ! :slight_smile: Enabled third parties and all is OK now! Thanks for your very fast feeback and support. Really appreciated!

If I can ask you again something … Where is the file to control the feedback windows?
In react directory I assume. Would like to change just some parts of it :slight_smile:

Oups, sorry. That was “easy” !!! In feedback directory :slight_smile:
Thanks again for your great support. Real community here !