Enable end-to-end encryption (Beta) not showing up

I do not see the “Enable end-to-end encryption (Beta)” option in my settings…? what am I missing?
also if my fellow is enabling it, I see/hear garbage, the question is how can I join in though?
I am using latest chrome browser. I have tried closing and restarting the session and browser. It did not help.

I used docker deployment and tested with the “Jitsi Meet Electron” client. The menu showed end-to-end encryption support (BETA), but I did not succeed in the browser. The test is still in the latest browser version (Google Chrome 83.0.4103.106) I don’t see the option “End-to-End Encryption”