Enable E2EE for Jitsi

Hello. I am new on Jitsi.

I have deployed Jitsi on my server. Now I want to enable e2ee option. How can I do this?

It’s available in the Security dialog. You can access it with the 3 dots menu in the toolbar. Note you need a browser with support for insertable streams, and at the moment that’s only Chrome.

I am testing on Latest Chrome. But it does not show. I think, I should enable that option on config. But I dont know which settings need to change and which file.

No, you don’t need to enable it, it’s available by default. Is your deployment availabnle publicly so I can test? Do you see any errors in the JS console?

type in
chrome://flags
in your browser window, search for “experimental web platform features”, enable it, restart browser and you should see the e2ee option in Jitsi Meet

Unfourtunately, it is locally only.

I have enabled. But no any update. No any option for it.

Are you seeing something like this?

image

If yes, scroll down and you will find that toggle option…

Btw on Chrome(and brave), No need to enable any experimental feature. It is visible by default.

It would help if you can paste the snapshot of what you see in “security options”. Always better to provide images, so that others know what you are observing.

Screenshot 2021-04-22 153051

There is no any option.

You have no lobby option visible too. Are you not the moderator?
Check this from an incognito window.

Even if you are not moderator E2EE should show though.

It seems you must be on prosody-10(or previous versions). That could be the reason why you are not seeing lobby option.

About E2EE, check when you are a moderator.

Your Jitsi Meet version seems old. What release are you running?

This issue was related my client machine. Now I can see e2ee option under security menu.