Enable conference mapper for local source installs?


#1

Hey Gang… it’s me again, I’m happy to report that everything seems to be running nicely so far on my install.
Thanks to Damian’s advice and some poking and prodding I’m finally slowly learning from my mistakes.

I am at the point now where I am panning on integrating my asterisk server a little more and I found that th post put up at https://evilcreamsicle.com/index.php/2018/03/28/jitsi-meet-w-call-in-and-active-directory/
is pretty much where I need to be.
My question this around is, " how do I implement conference mapper on my local install?
I have the /opt/jitsi-meet/doc folders and I see the cloud-api.swagger is here as well…
I’m just curious how I would go about having it run here. I’m under the impression that the cloud api is only used to query the jitsi.org instances?

thanks
jon


#3

My wish list is getting shorter.
So, I see that I can query my rooms with the Jitsi-api.jitsi.net provided tools
My hurdles are currently:

  1. Get the share box (copy link and dial in conference # to email) to display the room ID for users to dial into the IVR system

  2. Get the dial in numbers summary to display… I don’t know where or how to configure them… all queries return the default phone list of the online Jitsi conference services.

  3. Fix my ‘kick out’ participant feature. I can try to kick out people all day but nothing happens after I confirm the intention.

These are my top priorities. There are other issues but I feel once I get these figured out the others will be simple.

Thanks


#4

You need to create your own list of numbers and configure it in config.js:
dialInNumbersUrl: 'https://api.jitsi.net/phoneNumberList'. https://api.jitsi.net/phoneNumberList is the list of numbers meet.jit.si uses.

Which version of prosody are you using?

What do you mean?


#5

Thanks for the reply Damian

I got the info box to populate the dial in number.
Evidently I had an error in my file which caused an unexpected token

The prosody version is 0.9.10
I have the muc_owner_allow_kick_patch in my prosody_plugins folder
It seems that every time I join another user to the conference they are automatically granted Moderator… perhaps that is why i cannot kick them?

Thanks.


#6

You have this module active: mod_muc_allowners.lua, cause all your participants are moderators (same as meet.jit.si)

This file muc_owner_allow_kick.patch is not a prosody module but a patch the need to be applied to prosody. Mind that the patch is for prosody-trunk 747, if you want to apply it on 0.9.x, you need to do it by editing the prosody source code by hand, and mind that any update of the package will delete it.


#7

Thank you Damian. I have this thing almost 100%

Looks like the moderator issue is happening whe I connect with a sip client connecting via Asterisk IVR, and also with mobile devices using the app.

Chrome browser workstations are “ kickable “. Must be some setting buried I have missed.