Enable autmated quick-install using debconf-set-selections fails ($JVB_HOSTNAME is not read correctly)

#1

Hi
I’m trying to automate the quick-install of jitsi, using apt-get install -y jitsi meet.
I tried to preseed the questions asked by the install script using debconf-get-selections an debconf_set-selections.
But even if I set all selections to the right values (esp. the hostname), the installation of jitsi-meet-prosody fails because the get_db function can not correctly get the value vor $JVB_HOSTNAME and thus everything fails.
How is the correct way to automate the installation of jitsi / preseed the questions using debconf-set-selections?
thanks!

#2

It is possible to use debconf-set-selections, for host only set jitsi-videobridge/jvb-hostname, the rest of the packages will take it from there.

#3

Sorry but this is not working. I get the same error as before:

Setting up jitsi-meet-web-config (1.0.3216-1) ...
req: Use -help for summary.
dpkg: error processing package jitsi-meet-web-config (--configure):
 installed jitsi-meet-web-config package post-installation script subprocess returned error exit status 1
Setting up jitsi-meet-web (1.0.3216-1) ...
Setting up jitsi-meet-prosody (1.0.3216-1) ...
/var/lib/dpkg/info/jitsi-meet-prosody.postinst: line 92: [: /etc/prosody/conf.avail/: binary operator expected
/var/lib/dpkg/info/jitsi-meet-prosody.postinst: line 119: [: /var/lib/prosody/: binary operator expected
/var/lib/dpkg/info/jitsi-meet-prosody.postinst: line 128: [: /var/lib/prosody/auth.: binary operator expected
Processing triggers for systemd (237-3ubuntu10.15) ...
Setting up jicofo (1.0-458-1) ...
useradd: warning: the home directory already exists.
Not copying any file from skel directory into it.
dpkg: dependency problems prevent configuration of jitsi-meet:
 jitsi-meet depends on jitsi-meet-web-config (= 1.0.3216-1); however:
  Package jitsi-meet-web-config is not configured yet.

dpkg: error processing package jitsi-meet (--configure):
 dependency problems - leaving unconfigured
Processing triggers for ureadahead (0.100.0-20) ...
Processing triggers for systemd (237-3ubuntu10.15) ...
Errors were encountered while processing:
 jitsi-meet-web-config
 jitsi-meet

I set the following values via debconf-set-selections

jitsi-meet-web-config   jitsi-meet/cert-choice  select  I want to use my own certificate
jitsi-meet-web-config   jitsi-meet/cert-path-crt        string  /etc/ssl/myvalidcert.pem
jitsi-meet-web-config   jitsi-videobridge/jvb-hostname  string  fqdn.of.my.server
jitsi-meet-web-config   jitsi-meet/cert-path-key        string  /etc/ssl/myvalidkey.pem

The abvoe lines are in a file which I read via debconf-set-selections.
The values are from the manual installation.

#4

The errors you see are because this is not found:


Do not set this: jitsi-meet-web-config jitsi-videobridge/jvb-hostname ...
It should be enough to just set:
jitsi-videobridge jitsi-videobridge/jvb-hostname .... the rest of the packages should trigger dialog input when this is not found.

#5

thank you very much! that worked!